aboutsummaryrefslogtreecommitdiffstats
path: root/net/knc
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2013-02-10 01:55:38 +0800
committercrees <crees@FreeBSD.org>2013-02-10 01:55:38 +0800
commit555c3ac16e89ea04e6afdf0c750379ec11dbe73c (patch)
treeecaa161d76e983f8823b713d2404a5fffc9a82cd /net/knc
parent1c94dafffda342e4ba404b111e38dea890a30f80 (diff)
downloadfreebsd-ports-gnome-555c3ac16e89ea04e6afdf0c750379ec11dbe73c.tar.gz
freebsd-ports-gnome-555c3ac16e89ea04e6afdf0c750379ec11dbe73c.tar.zst
freebsd-ports-gnome-555c3ac16e89ea04e6afdf0c750379ec11dbe73c.zip
KNC is Kerberised NetCat. It works in basically the same way as either netcat
or stunnel except that it is uses GSS-API to secure the communication. You can use it to construct client/server applications while keeping the Kerberos libraries out of your programs address space quickly and easily. WWW: http://oskt.secure-endpoints.com/knc.html PR: ports/175952 Submitted by: Denis Generalov <gd@rambler-co.ru>
Diffstat (limited to 'net/knc')
-rw-r--r--net/knc/Makefile17
-rw-r--r--net/knc/distinfo2
-rw-r--r--net/knc/files/patch-bin__knc.c11
-rw-r--r--net/knc/pkg-descr6
4 files changed, 36 insertions, 0 deletions
diff --git a/net/knc/Makefile b/net/knc/Makefile
new file mode 100644
index 000000000000..c731eac60c3f
--- /dev/null
+++ b/net/knc/Makefile
@@ -0,0 +1,17 @@
+# Created by: Denis Generalov <gd@rambler-co.ru>
+# $FreeBSD$
+
+PORTNAME= knc
+PORTVERSION= 1.7
+CATEGORIES= net
+MASTER_SITES= http://oskt.secure-endpoints.com/downloads/
+
+MAINTAINER= gd@rambler-co.ru
+COMMENT= KNC is Kerberised NetCat
+
+USE_AUTOTOOLS= libtool
+MAN1= knc.1
+
+PLIST_FILES= bin/knc
+
+.include <bsd.port.mk>
diff --git a/net/knc/distinfo b/net/knc/distinfo
new file mode 100644
index 000000000000..09b48a3d9ef7
--- /dev/null
+++ b/net/knc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (knc-1.7.tar.gz) = d36cdec27dc505a6eca4f230bc53dafcee422122bd2ec6addc0af0c35a95f46f
+SIZE (knc-1.7.tar.gz) = 646756
diff --git a/net/knc/files/patch-bin__knc.c b/net/knc/files/patch-bin__knc.c
new file mode 100644
index 000000000000..b485b1a3e51e
--- /dev/null
+++ b/net/knc/files/patch-bin__knc.c
@@ -0,0 +1,11 @@
+--- ./bin/knc.c.orig 2013-02-09 21:09:13.000000000 +0400
++++ ./bin/knc.c 2013-02-09 21:09:29.000000000 +0400
+@@ -47,7 +47,7 @@
+ #include <time.h>
+ #include <unistd.h>
+
+-#include "gssapi/gssapi.h"
++#include "config.h"
+ #include "gssstdio.h"
+ #include "knc.h"
+
diff --git a/net/knc/pkg-descr b/net/knc/pkg-descr
new file mode 100644
index 000000000000..8576df35239b
--- /dev/null
+++ b/net/knc/pkg-descr
@@ -0,0 +1,6 @@
+KNC is Kerberised NetCat. It works in basically the same way as either netcat
+or stunnel except that it is uses GSS-API to secure the communication. You can
+use it to construct client/server applications while keeping the Kerberos
+libraries out of your programs address space quickly and easily.
+
+WWW: http://oskt.secure-endpoints.com/knc.html