aboutsummaryrefslogtreecommitdiffstats
path: root/net/ldapdiff
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-08-15 02:00:01 +0800
committerdinoex <dinoex@FreeBSD.org>2003-08-15 02:00:01 +0800
commite83b350340ec9b453208060f6d7cbe6a6814fda3 (patch)
treebfc71db2f99ccc051b0bcd49dd45a18ecb0cd4db /net/ldapdiff
parentea31082ef89fefee826058785923b779816d28ac (diff)
downloadfreebsd-ports-gnome-e83b350340ec9b453208060f6d7cbe6a6814fda3.tar.gz
freebsd-ports-gnome-e83b350340ec9b453208060f6d7cbe6a6814fda3.tar.zst
freebsd-ports-gnome-e83b350340ec9b453208060f6d7cbe6a6814fda3.zip
- New option LDAP_PORT
- Fix LIB_DEPENDS to catch rename of openldap20 to openldap20-client - Make portlint happier
Diffstat (limited to 'net/ldapdiff')
-rw-r--r--net/ldapdiff/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/net/ldapdiff/Makefile b/net/ldapdiff/Makefile
index 77b75aa1ee2e..5b6c16bfe220 100644
--- a/net/ldapdiff/Makefile
+++ b/net/ldapdiff/Makefile
@@ -5,27 +5,27 @@
# $FreeBSD$
#
-PORTNAME= ldapdiff
-PORTVERSION= 0.9.0
-CATEGORIES= net
-MASTER_SITES= http://webtomware.rhoen.de/ \
+PORTNAME= ldapdiff
+PORTVERSION= 0.9.0
+CATEGORIES= net
+MASTER_SITES= http://webtomware.rhoen.de/ \
http://unixpages.org/distfiles/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A utility for patching LDAP directories using LDIF files
LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
+.if defined(WITH_OPENLDAP1)
+LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap12
+.else
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/${LDAP_PORT}
+.endif
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--with-ldap-dir=${PREFIX} \
--with-iconv-dir=${PREFIX}
-
-.if defined(WITH_OPENLDAP1)
-LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap12
-.else
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap20
-.endif
+LDAP_PORT?= net/openldap20-client
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ldapdiff ${PREFIX}/bin