aboutsummaryrefslogtreecommitdiffstats
path: root/net/ldapsh
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-28 20:46:39 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-28 20:46:39 +0800
commitb33b30947050d7236099e994c6074e8f43c21849 (patch)
tree5bc21ac2110ac4875b1d24a4735370a51f907577 /net/ldapsh
parent19d34bb573dbed0d4a86c038ffcaa7218dedf884 (diff)
downloadfreebsd-ports-gnome-b33b30947050d7236099e994c6074e8f43c21849.tar.gz
freebsd-ports-gnome-b33b30947050d7236099e994c6074e8f43c21849.tar.zst
freebsd-ports-gnome-b33b30947050d7236099e994c6074e8f43c21849.zip
Stagify a bunch of ports maintained by flz
While here: - graphics/icoconvert: * Respect CC * Use modern LIB_DEPENDS - net/grdesktop: * Convert gnomehack to pathfix - net/ldapsh: * Use shebangfix instead of custom post-patch target - net-im/py-jabber: * Use autoplist - net-p2p/bnbt: * Use the options framework * Convert to dos2unix * Respect CXX * Do not renamed base on option - sysutils/testdisk: * Update to 6.14 * Use options helpers * Use modern LIB_DEPENDS * Convert USE_BZIP2 -> USES=tar:bzip2
Diffstat (limited to 'net/ldapsh')
-rw-r--r--net/ldapsh/Makefile18
-rw-r--r--net/ldapsh/pkg-plist5
2 files changed, 10 insertions, 13 deletions
diff --git a/net/ldapsh/Makefile b/net/ldapsh/Makefile
index 94e0fd2e7cea..9cc841c3749a 100644
--- a/net/ldapsh/Makefile
+++ b/net/ldapsh/Makefile
@@ -21,21 +21,13 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
SUB_FILES= pkg-message
-MAN1= ldapsh.1
-MAN3= Net::LDAP::Shell.3 Net::LDAP::Config.3 \
- Net::LDAP::Shell::Parse.3 Net::LDAP::Shell::Util.3
-
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= configure
-
-NO_STAGE= yes
-post-patch:
- ${REINPLACE_CMD} -e "s,/usr/local/bin/perl,${PERL}," ${WRKSRC}/ldapsh
+SHEBANG_FILES= ldapsh
post-install:
- ${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/COMMANDS ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/examples/ldapsh_config ${EXAMPLESDIR}/
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COMMANDS ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/examples/ldapsh_config ${STAGEDIR}${EXAMPLESDIR}/
.include <bsd.port.mk>
diff --git a/net/ldapsh/pkg-plist b/net/ldapsh/pkg-plist
index ec5a6e113adc..c4c45fea674d 100644
--- a/net/ldapsh/pkg-plist
+++ b/net/ldapsh/pkg-plist
@@ -20,6 +20,11 @@ bin/ldapsh
%%SITE_PERL%%/Net/LDAP/Shell/Util.pm
%%SITE_PERL%%/Net/LDAP/Shell/grammar.yp
%%SITE_PERL%%/Net/LDAP/Shell/makefile
+%%PERL5_MAN3%%/Net::LDAP::Config.3.gz
+%%PERL5_MAN3%%/Net::LDAP::Shell.3.gz
+%%PERL5_MAN3%%/Net::LDAP::Shell::Parse.3.gz
+%%PERL5_MAN3%%/Net::LDAP::Shell::Util.3.gz
+man/man1/ldapsh.1.gz
%%DOCSDIR%%/COMMANDS
%%EXAMPLESDIR%%/ldapsh_config
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/ldapsh