aboutsummaryrefslogtreecommitdiffstats
path: root/net/libdnet
diff options
context:
space:
mode:
authortmclaugh <tmclaugh@FreeBSD.org>2007-03-13 01:51:53 +0800
committertmclaugh <tmclaugh@FreeBSD.org>2007-03-13 01:51:53 +0800
commit98acc4f997ac6f6d7ce6fc9ec9c9cb4dea53e7cb (patch)
treed4f038da6fcb2a56c54ffc14da0676461ce5d881 /net/libdnet
parent6f2a9052d6775cee6169902d9f603b1ac8275ffb (diff)
downloadfreebsd-ports-gnome-98acc4f997ac6f6d7ce6fc9ec9c9cb4dea53e7cb.tar.gz
freebsd-ports-gnome-98acc4f997ac6f6d7ce6fc9ec9c9cb4dea53e7cb.tar.zst
freebsd-ports-gnome-98acc4f997ac6f6d7ce6fc9ec9c9cb4dea53e7cb.zip
Fix py-libdnet.
The py-libdnet port has been seperated out as a slave port to libdnet and is now dependent on libdnet. py-libdnet now only installs the libdnet python module. Since files previously owned by py-libdnet are now owned by its dependency, in order to upgrade correctly, py-libdnet must be deinstall and then reinstalled manually. PR: 109262 Submitted by: thierry and me Approved by: maintainer timeout
Diffstat (limited to 'net/libdnet')
-rw-r--r--net/libdnet/Makefile37
-rw-r--r--net/libdnet/pkg-plist50
2 files changed, 31 insertions, 56 deletions
diff --git a/net/libdnet/Makefile b/net/libdnet/Makefile
index 7c928966a314..126d5ccf5855 100644
--- a/net/libdnet/Makefile
+++ b/net/libdnet/Makefile
@@ -7,50 +7,29 @@
PORTNAME= libdnet
PORTVERSION= 1.11
-CATEGORIES= net
+PORTREVISION?= 1
+CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-.if defined(BUILD_PYTHON_MODULE)
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-.endif
-MAINTAINER= onatan@gmail.com
+MAINTAINER?= onatan@gmail.com
COMMENT?= A simple interface to low level networking routines
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-SLAVE_DIRS= net/py-libdnet
-
-.if defined(BUILD_PYTHON_MODULE)
-USE_PYTHON= yes
-CONFIGURE_ARGS+= --with-python
-INSTALL_WRKSRC= ${BUILD_WRKSRC}/python
-PLIST_FILES= %%PYTHON_SITELIBDIR%%/dnet.so
-PLIST_SUB+= MASTER="@comment "
-.else
-CONFIGURE_ARGS+= --without-python
+.if !defined(LIBDNET_SLAVE)
+CONFIGURE_ARGS+=--without-python
USE_LDCONFIG= yes
-PLIST_SUB+= MASTER=""
MAN3= dnet.3
MAN8= dnet.8
.endif
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= doesn't build on FreeBSD 4.x
-.endif
-
-pre-everything::
-.if !defined(BUILD_PYTHON_MODULE)
- @${ECHO_MSG} "===>"
- @${ECHO_MSG} "===> You can add python support with the port ${SLAVE_DIRS}."
- @${ECHO_MSG} "===>"
- @sleep 2
-.endif
+.if !defined(LIBDNET_SLAVE)
post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
@@ -61,10 +40,6 @@ post-build:
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME}.so ${PREFIX}/lib/
@${LN} ${PREFIX}/lib/${PORTNAME}.so ${PREFIX}/lib/${PORTNAME}.so.1
-
-.if defined(BUILD_PYTHON_MODULE) && defined(MAINTAINER_MODE)
-test: install
- ${PYTHON_CMD} ${INSTALL_WRKSRC}/test.py
.endif
.include <bsd.port.post.mk>
diff --git a/net/libdnet/pkg-plist b/net/libdnet/pkg-plist
index a111ab699324..58d3c68913cb 100644
--- a/net/libdnet/pkg-plist
+++ b/net/libdnet/pkg-plist
@@ -1,25 +1,25 @@
-%%MASTER%%sbin/dnet
-%%MASTER%%bin/dnet-config
-%%MASTER%%lib/libdnet
-%%MASTER%%lib/libdnet.1
-%%MASTER%%lib/libdnet.a
-%%MASTER%%lib/libdnet.la
-%%MASTER%%lib/libdnet.so
-%%MASTER%%lib/libdnet.so.1
-%%MASTER%%include/dnet.h
-%%MASTER%%include/dnet/addr.h
-%%MASTER%%include/dnet/arp.h
-%%MASTER%%include/dnet/blob.h
-%%MASTER%%include/dnet/eth.h
-%%MASTER%%include/dnet/fw.h
-%%MASTER%%include/dnet/icmp.h
-%%MASTER%%include/dnet/intf.h
-%%MASTER%%include/dnet/ip.h
-%%MASTER%%include/dnet/ip6.h
-%%MASTER%%include/dnet/os.h
-%%MASTER%%include/dnet/rand.h
-%%MASTER%%include/dnet/route.h
-%%MASTER%%include/dnet/tcp.h
-%%MASTER%%include/dnet/tun.h
-%%MASTER%%include/dnet/udp.h
-%%MASTER%%@dirrm include/dnet
+sbin/dnet
+bin/dnet-config
+lib/libdnet
+lib/libdnet.1
+lib/libdnet.a
+lib/libdnet.la
+lib/libdnet.so
+lib/libdnet.so.1
+include/dnet.h
+include/dnet/addr.h
+include/dnet/arp.h
+include/dnet/blob.h
+include/dnet/eth.h
+include/dnet/fw.h
+include/dnet/icmp.h
+include/dnet/intf.h
+include/dnet/ip.h
+include/dnet/ip6.h
+include/dnet/os.h
+include/dnet/rand.h
+include/dnet/route.h
+include/dnet/tcp.h
+include/dnet/tun.h
+include/dnet/udp.h
+@dirrm include/dnet