aboutsummaryrefslogtreecommitdiffstats
path: root/net/libgnetwork
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-01-03 16:32:58 +0800
committermarcus <marcus@FreeBSD.org>2004-01-03 16:32:58 +0800
commit5ed1da32475b864f77380240cef7e52278a1b37e (patch)
tree53fb83f7af859395cf5cd6592eaac718b452a382 /net/libgnetwork
parentf697693dac1c719a7ea0b07ea4f332bbc57a88d9 (diff)
downloadfreebsd-ports-gnome-5ed1da32475b864f77380240cef7e52278a1b37e.tar.gz
freebsd-ports-gnome-5ed1da32475b864f77380240cef7e52278a1b37e.tar.zst
freebsd-ports-gnome-5ed1da32475b864f77380240cef7e52278a1b37e.zip
Add libgnetwork, a glib-2 network abstraction API.
Diffstat (limited to 'net/libgnetwork')
-rw-r--r--net/libgnetwork/Makefile45
-rw-r--r--net/libgnetwork/distinfo1
-rw-r--r--net/libgnetwork/files/patch-Makefile.in11
-rw-r--r--net/libgnetwork/files/patch-configure10
-rw-r--r--net/libgnetwork/files/patch-data_Makefile.in10
-rw-r--r--net/libgnetwork/pkg-descr11
-rw-r--r--net/libgnetwork/pkg-plist31
7 files changed, 119 insertions, 0 deletions
diff --git a/net/libgnetwork/Makefile b/net/libgnetwork/Makefile
new file mode 100644
index 000000000000..8f7918987cbb
--- /dev/null
+++ b/net/libgnetwork/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: libgnetwork
+# Date created: 11 December 2003
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgnetwork
+PORTVERSION= 0.0.4
+CATEGORIES= net gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.0
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A GLib-based networking wrapper
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GNOME= gnomeprefix gnomehack gconf2
+INSTALLS_SHLIB= yes
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.if !defined(WITHOUT_SSL)
+LIB_DEPENDS+= gnutls.7:${PORTSDIR}/security/gnutls
+CONFIGURE_ARGS+=--enable-ssl=gnutls
+.else
+CONFIGURE_ARGS+=--enable-ssl=no
+.endif
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "libgnetwork has the following configurable option(s):"
+ @${ECHO_MSG} " WITHOUT_SSL Disable GnuTLS SSL support"
+ @${ECHO_MSG} ""
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "intltool-merge.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|mkdir $$lang or|mkdir $$lang, 0777 or| ; \
+ s|^push @INC, "/.*|push @INC, "${LOCALBASE}/share/intltool";|'
+
+.include <bsd.port.mk>
diff --git a/net/libgnetwork/distinfo b/net/libgnetwork/distinfo
new file mode 100644
index 000000000000..ebf5ee23bf9d
--- /dev/null
+++ b/net/libgnetwork/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/libgnetwork-0.0.4.tar.bz2) = 8945ba82695613a09f1947b10d80a9e8
diff --git a/net/libgnetwork/files/patch-Makefile.in b/net/libgnetwork/files/patch-Makefile.in
new file mode 100644
index 000000000000..bfedc0255042
--- /dev/null
+++ b/net/libgnetwork/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Fri Dec 12 01:51:23 2003
++++ Makefile.in Fri Dec 12 01:51:29 2003
+@@ -197,7 +197,7 @@
+
+ AUTOMAKE_OPTIONS = 1.7
+
+-SUBDIRS = libgnetwork tests data doc po
++SUBDIRS = libgnetwork data doc po
+
+ EXTRA_DIST = \
+ intltool-merge.in \
diff --git a/net/libgnetwork/files/patch-configure b/net/libgnetwork/files/patch-configure
new file mode 100644
index 000000000000..f195f07b43c6
--- /dev/null
+++ b/net/libgnetwork/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Wed Dec 11 18:31:51 2002
++++ configure Thu Dec 12 12:07:17 2002
+@@ -7414,6 +7414,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/net/libgnetwork/files/patch-data_Makefile.in b/net/libgnetwork/files/patch-data_Makefile.in
new file mode 100644
index 000000000000..741e38dc9c04
--- /dev/null
+++ b/net/libgnetwork/files/patch-data_Makefile.in
@@ -0,0 +1,10 @@
+--- data/Makefile.in.orig Fri Dec 12 02:11:14 2003
++++ data/Makefile.in Fri Dec 12 02:11:34 2003
+@@ -419,7 +419,6 @@
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schema_DATA) ; do \
+ if test -f $(srcdir)/$$p ; then \
+- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p ; \
+ fi \
+ done \
+ fi
diff --git a/net/libgnetwork/pkg-descr b/net/libgnetwork/pkg-descr
new file mode 100644
index 000000000000..2a8487b69f22
--- /dev/null
+++ b/net/libgnetwork/pkg-descr
@@ -0,0 +1,11 @@
+GNetwork is a networking wrapper written in pure C against the Glib/GObject
+object framework.
+
+The intention here is to provide a useful and easy-to-develop-against sockets
+wrapper for GNOME2 & GTK+ 2.0 programs which require TCP/IP connection
+capabilities. It can be used by programs which do not use GNOME or GTK+
+anyways,however. It is NOT recommended or intended for high-load server
+situations, just user applications which need TCP/IP networking. Proxies are
+supported completely transparently, using the same settings as gnome-vfs.
+
+-- The libgnetwork README
diff --git a/net/libgnetwork/pkg-plist b/net/libgnetwork/pkg-plist
new file mode 100644
index 000000000000..23ca76d2905d
--- /dev/null
+++ b/net/libgnetwork/pkg-plist
@@ -0,0 +1,31 @@
+etc/gconf/schemas/libgnetwork.schemas
+include/libgnetwork-1.0/libgnetwork/gnetwork-connection.h
+include/libgnetwork-1.0/libgnetwork/gnetwork-datagram.h
+include/libgnetwork-1.0/libgnetwork/gnetwork-dns.h
+include/libgnetwork-1.0/libgnetwork/gnetwork-errors.h
+include/libgnetwork-1.0/libgnetwork/gnetwork-interfaces.h
+include/libgnetwork-1.0/libgnetwork/gnetwork-ip-address.h
+include/libgnetwork-1.0/libgnetwork/gnetwork-ip-multicast.h
+include/libgnetwork-1.0/libgnetwork/gnetwork-macros.h
+include/libgnetwork-1.0/libgnetwork/gnetwork-server.h
+include/libgnetwork-1.0/libgnetwork/gnetwork-ssl.h
+include/libgnetwork-1.0/libgnetwork/gnetwork-tcp-connection.h
+include/libgnetwork-1.0/libgnetwork/gnetwork-tcp-proxy.h
+include/libgnetwork-1.0/libgnetwork/gnetwork-tcp-server.h
+include/libgnetwork-1.0/libgnetwork/gnetwork-threads.h
+include/libgnetwork-1.0/libgnetwork/gnetwork-type-builtins.h
+include/libgnetwork-1.0/libgnetwork/gnetwork-udp-datagram.h
+include/libgnetwork-1.0/libgnetwork/gnetwork-unix-connection.h
+include/libgnetwork-1.0/libgnetwork/gnetwork-unix-server.h
+include/libgnetwork-1.0/libgnetwork/gnetwork.h
+lib/libgnetwork-1.0.a
+lib/libgnetwork-1.0.so
+lib/libgnetwork-1.0.so.0
+libdata/pkgconfig/libgnetwork-1.0.pc
+%%DOCSDIR%%/home.png
+%%DOCSDIR%%/left.png
+%%DOCSDIR%%/right.png
+%%DOCSDIR%%/up.png
+@dirrm %%DOCSDIR%%
+@dirrm include/libgnetwork-1.0/libgnetwork
+@dirrm include/libgnetwork-1.0