aboutsummaryrefslogtreecommitdiffstats
path: root/net/libicq2000
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-08-08 21:16:32 +0800
committerlioux <lioux@FreeBSD.org>2002-08-08 21:16:32 +0800
commit25f5567721675127b74e6ae252a210eacc5475e9 (patch)
treeaa3f3096df2cd8887dc0c25f2124e1e2aee273c9 /net/libicq2000
parent74081bcb9e7f12ee268fcc1e35a049f9f63ca5b8 (diff)
downloadfreebsd-ports-gnome-25f5567721675127b74e6ae252a210eacc5475e9.tar.gz
freebsd-ports-gnome-25f5567721675127b74e6ae252a210eacc5475e9.tar.zst
freebsd-ports-gnome-25f5567721675127b74e6ae252a210eacc5475e9.zip
* libicq2000
- Return correct cflags when libicq2000-config is called [1] - USE_REINPLACE - Bump PORTREVISION * ickle - Patch to work with aforementioned fix Prompted by: Neil Darlow <neil@darlow.co.uk> [1]
Diffstat (limited to 'net/libicq2000')
-rw-r--r--net/libicq2000/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/net/libicq2000/Makefile b/net/libicq2000/Makefile
index 2e483c22501c..c1079f690d71 100644
--- a/net/libicq2000/Makefile
+++ b/net/libicq2000/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libicq2000
PORTVERSION= 0.3.2
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,6 +17,7 @@ MAINTAINER= lioux@FreeBSD.org
LIB_DEPENDS= sigc.1:${PORTSDIR}/devel/libsigc++
USE_LIBTOOL= yes
+USE_REINPLACE= yes
MAN1= libicq2000-config.1
@@ -23,14 +25,16 @@ DOC_FILES= AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS \
TODO
post-patch:
- @${PERL} -pi -e \
+ @${REINPLACE_CMD} -E -e \
's|^(headersincludedir =).+|\1\$$(includedir)/libicq2000|' \
${WRKSRC}/libicq2000/Makefile.in
- @${PERL} -pi -e 's|(iomanip).h|\1|' ${WRKSRC}/libicq2000/buffer.h
+ @${REINPLACE_CMD} -E -e 's|^(pkgincludedir.+)/@PACKAGE@|\1|' \
+ ${WRKSRC}/libicq2000-config.in
post-configure:
@${CP} ${LOCALBASE}/bin/libtool ${WRKSRC}
- @${PERL} -pi -e 's|^(install_ltlibs=).*|\1no|' ${WRKSRC}/libtool
+ @${REINPLACE_CMD} -E -e 's|^(install_ltlibs=).+$$|\1no|' \
+ ${WRKSRC}/libtool
post-install:
.ifndef(NOPORTDOCS)