aboutsummaryrefslogtreecommitdiffstats
path: root/net/libksieve
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /net/libksieve
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'net/libksieve')
-rw-r--r--net/libksieve/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/libksieve/Makefile b/net/libksieve/Makefile
index e8c7c2e1e1f2..970b43860c3d 100644
--- a/net/libksieve/Makefile
+++ b/net/libksieve/Makefile
@@ -12,14 +12,14 @@ LICENSE= LGPL21
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libsasl2.so:security/cyrus-sasl2
-USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 qt:5 tar:xz
USE_KDE= archive attica auth codecs completion config configwidgets \
coreaddons ecm i18n iconthemes jobwidgets kio newstuff service \
sonnet syntaxhighlighting wallet widgetsaddons windowsystem xmlgui
# pim components
USE_KDE+= akonadi identitymanagement libkdepim mailtransport mime \
pimcommon pimtextedit
-USE_QT5= core dbus gui location network printsupport qml quick testlib \
+USE_QT= core dbus gui location network printsupport qml quick testlib \
uitools webchannel webengine widgets xml \
buildtools_build qmake_build
USE_LDCONFIG= yes