aboutsummaryrefslogtreecommitdiffstats
path: root/net/libvncserver
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-27 09:08:30 +0800
committermarino <marino@FreeBSD.org>2014-07-27 09:08:30 +0800
commit9f89d883004ba89c69e8b20ab35322db36b86eac (patch)
treec130dab297d95f7cc8458cd8dd30e84649364331 /net/libvncserver
parentea7f74105085dbdb9ccedbc209a78f2946e4dd17 (diff)
downloadfreebsd-ports-gnome-9f89d883004ba89c69e8b20ab35322db36b86eac.tar.gz
freebsd-ports-gnome-9f89d883004ba89c69e8b20ab35322db36b86eac.tar.zst
freebsd-ports-gnome-9f89d883004ba89c69e8b20ab35322db36b86eac.zip
net/libvncserver: fix compile warning
PR: 191527 Submitted by: Duane
Diffstat (limited to 'net/libvncserver')
-rw-r--r--net/libvncserver/Makefile4
-rw-r--r--net/libvncserver/files/patch-libvncserver_rfbregion.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/net/libvncserver/Makefile b/net/libvncserver/Makefile
index 850e9e05df2d..da1ae7b23b3b 100644
--- a/net/libvncserver/Makefile
+++ b/net/libvncserver/Makefile
@@ -3,13 +3,13 @@
PORTNAME= libvncserver
PORTVERSION= 0.9.9
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net devel
MASTER_SITES= SF
DISTNAME= LibVNCServer-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= Provide an easy API to write one's own vnc server
+COMMENT= Provide an easy API to a custom vnc server
LICENSE= GPLv2
diff --git a/net/libvncserver/files/patch-libvncserver_rfbregion.c b/net/libvncserver/files/patch-libvncserver_rfbregion.c
new file mode 100644
index 000000000000..d85072474dbb
--- /dev/null
+++ b/net/libvncserver/files/patch-libvncserver_rfbregion.c
@@ -0,0 +1,11 @@
+--- ./libvncserver/rfbregion.c.orig 2014-07-01 23:00:03.428441834 +1000
++++ ./libvncserver/rfbregion.c 2014-07-01 23:00:14.275274256 +1000
+@@ -751,7 +751,7 @@
+ i->ptrSize += DEFSTEP;
+ i->sPtrs = (sraSpan**)realloc(i->sPtrs, sizeof(sraSpan*)*i->ptrSize);
+ }
+- i->ptrPos =+ 2;
++ i->ptrPos += 2;
+ if(sraReverse(i)) {
+ i->sPtrs[i->ptrPos] = i->sPtrs[i->ptrPos-2]->subspan->back._prev;
+ i->sPtrs[i->ptrPos+1] = &(i->sPtrs[i->ptrPos-2]->subspan->front);