aboutsummaryrefslogtreecommitdiffstats
path: root/net/linknx
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-10-03 20:37:55 +0800
committermat <mat@FreeBSD.org>2014-10-03 20:37:55 +0800
commitf7e50b2c0ed4b69a7837c93ddd48ea4bc3df862b (patch)
treed79d9bef65a0e80b0114080c852097ffd4189b90 /net/linknx
parente61c0cbef04a1c2fd77cba73d7bbef0188331545 (diff)
downloadfreebsd-ports-gnome-f7e50b2c0ed4b69a7837c93ddd48ea4bc3df862b.tar.gz
freebsd-ports-gnome-f7e50b2c0ed4b69a7837c93ddd48ea4bc3df862b.tar.zst
freebsd-ports-gnome-f7e50b2c0ed4b69a7837c93ddd48ea4bc3df862b.zip
Make buildable again by upgrading to 0.0.1.32.
Sponsored by: Absolight
Diffstat (limited to 'net/linknx')
-rw-r--r--net/linknx/Makefile12
-rw-r--r--net/linknx/distinfo4
-rw-r--r--net/linknx/files/patch-src__ioport.cpp10
3 files changed, 7 insertions, 19 deletions
diff --git a/net/linknx/Makefile b/net/linknx/Makefile
index e5e607d02d01..46295400c0c4 100644
--- a/net/linknx/Makefile
+++ b/net/linknx/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= linknx
-PORTVERSION= 0.0.1.30
-PORTREVISION= 2
+PORTVERSION= 0.0.1.32
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -12,15 +11,11 @@ COMMENT= Rule-based event handling in a KNX installation
LICENSE= GPLv2
-BROKEN= Fails to configure
-
LIB_DEPENDS= libpthsem.so:${PORTSDIR}/devel/pthsem
BUILD_DEPENDS= ${LOCALBASE}/lib/libargp.a:${PORTSDIR}/devel/argp-standalone
-USES= gmake
+USES= gmake autoreconf pkgconfig
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf aclocal automake
-AUTOMAKE_ARGS= --add-missing --copy --force-missing --foreign
CONFIGURE_ARGS+=CFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-I${LOCALBASE}/include -L/${LOCALBASE}/lib"
@@ -36,6 +31,8 @@ LIBESMTP_CONFIGURE_ENABLE= smtp
LIBESMTP_LIB_DEPENDS= libesmtp.so:${PORTSDIR}/mail/libesmtp
LIBCURL_CONFIGURE_WITH= libcurl
LIBCURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+# autoreconf needs that anyway.
+LIBCURL_BUILD_DEPENDS_OFF= ${LOCALBASE}/share/aclocal/libcurl.m4:${PORTSDIR}/ftp/curl
LIBLUA_CONFIGURE_WITH= lua
LIBLUA_USES= lua
LIBLUA_CFLAGS= -I${LUA_INCDIR}
@@ -52,5 +49,6 @@ USE_RC_SUBR= ${PORTNAME}
post-patch:
${REINPLACE_CMD} "s/LUAPC=lua/LUAPC=lua-${LUA_VER}/" ${WRKSRC}/configure.ac
+ cd ${WRKSRC} && ${TOUCH} NEWS README AUTHORS
.include <bsd.port.mk>
diff --git a/net/linknx/distinfo b/net/linknx/distinfo
index 673501ad137a..6d1651c104b4 100644
--- a/net/linknx/distinfo
+++ b/net/linknx/distinfo
@@ -1,2 +1,2 @@
-SHA256 (linknx-0.0.1.30.tar.gz) = 46e60620ad29d69bf3a1a3e9529322443c0d585e7e676ca7d441042b5fcad25e
-SIZE (linknx-0.0.1.30.tar.gz) = 327809
+SHA256 (linknx-0.0.1.32.tar.gz) = f161d3c8da3b8c6969e9c02d84d3cd26eb5e7fb4f3a3efbaaede8acdaaf11700
+SIZE (linknx-0.0.1.32.tar.gz) = 336875
diff --git a/net/linknx/files/patch-src__ioport.cpp b/net/linknx/files/patch-src__ioport.cpp
deleted file mode 100644
index 8e31e0b1cbb5..000000000000
--- a/net/linknx/files/patch-src__ioport.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/ioport.cpp.orig 2011-03-08 22:20:17.000000000 +0100
-+++ ./src/ioport.cpp 2014-04-22 19:17:42.208791119 +0200
-@@ -21,6 +21,7 @@
- #include <iomanip>
- #include "ioport.h"
- #include <fcntl.h>
-+#include <unistd.h>
-
- Logger& IOPort::logger_m(Logger::getInstance("IOPort"));
- Logger& RxThread::logger_m(Logger::getInstance("RxThread"));