aboutsummaryrefslogtreecommitdiffstats
path: root/net/mpich2
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-12 13:21:25 +0800
committermaho <maho@FreeBSD.org>2007-01-12 13:21:25 +0800
commitd752a3b087a9d6e63b119554025a900760d73929 (patch)
treef34668e62c225dacd4324dff8be8d276bd2a16b5 /net/mpich2
parentcd0be627e57db169dc8cc88c21af77d288eb1f16 (diff)
downloadfreebsd-ports-gnome-d752a3b087a9d6e63b119554025a900760d73929.tar.gz
freebsd-ports-gnome-d752a3b087a9d6e63b119554025a900760d73929.tar.zst
freebsd-ports-gnome-d752a3b087a9d6e63b119554025a900760d73929.zip
Only use of gfortran42. not gcc42. this breaks a lot of programs...
Approved by: portmgr (kris)
Diffstat (limited to 'net/mpich2')
-rw-r--r--net/mpich2/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/mpich2/Makefile b/net/mpich2/Makefile
index b4d9565752bf..8bf6b7bd2688 100644
--- a/net/mpich2/Makefile
+++ b/net/mpich2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mpich2
PORTVERSION= 1.0.5p1
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= net parallel
MASTER_SITES= ftp://ftp.mcs.anl.gov/pub/mpi/ \
@@ -40,7 +41,9 @@ NOCCACHE= yes
MAKE_ENV= CCACHE_DISABLE=yes
WANT_FORTRAN= yes
-USE_GCC=4.2+
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
F90FLAGS+= ${FFLAGS}
CONFIGURE_ENV+= F90=${FC} F90FLAGS=${F90FLAGS} F77=${FC}