aboutsummaryrefslogtreecommitdiffstats
path: root/net/mtr
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-05 12:07:53 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-05 12:07:53 +0800
commit43b07ba130eba64227d7ed3f032f4d6848f4fd32 (patch)
tree129dd15475a6f670540bfd0f96108dc8a8c53d71 /net/mtr
parentbebad335a7a32fff167960c0d5713f97f3c9b6dc (diff)
downloadfreebsd-ports-gnome-43b07ba130eba64227d7ed3f032f4d6848f4fd32.tar.gz
freebsd-ports-gnome-43b07ba130eba64227d7ed3f032f4d6848f4fd32.tar.zst
freebsd-ports-gnome-43b07ba130eba64227d7ed3f032f4d6848f4fd32.zip
Update to 0.93
Changes: https://github.com/traviscross/mtr/blob/master/NEWS
Diffstat (limited to 'net/mtr')
-rw-r--r--net/mtr/Makefile21
-rw-r--r--net/mtr/distinfo6
-rw-r--r--net/mtr/files/patch-packet-probe_unix.c25
-rw-r--r--net/mtr/files/patch-ui-mtr.c12
4 files changed, 38 insertions, 26 deletions
diff --git a/net/mtr/Makefile b/net/mtr/Makefile
index 64c4e005e260..b7c01da706de 100644
--- a/net/mtr/Makefile
+++ b/net/mtr/Makefile
@@ -2,11 +2,9 @@
# $FreeBSD$
PORTNAME= mtr
-PORTVERSION= 0.92
-PORTREVISION= 1
+PORTVERSION= 0.93
+DISTVERSIONPREFIX= v
CATEGORIES= net
-MASTER_SITES= https://www.bitwizard.nl/mtr/files/ \
- LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Traceroute and ping in a single network diagnostic tool
@@ -14,26 +12,27 @@ COMMENT= Traceroute and ping in a single network diagnostic tool
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+USES= autoreconf ncurses pkgconfig
+
+GNU_CONFIGURE= yes
+LDFLAGS+= -lncurses
+
+GH_ACCOUNT= traviscross
+USE_GITHUB= yes
+
CONFLICTS_INSTALL?= mtr-nox11
OPTIONS_DEFINE= IPV6 X11
OPTIONS_DEFAULT=X11
X11_DESC= Build X11-enabled mtr
-USES= autoreconf ncurses pkgconfig
-
-GNU_CONFIGURE= yes
-LDFLAGS+= -lncurses
-
IPV6_CONFIGURE_ENABLE= ipv6
X11_CONFIGURE_WITH= gtk
X11_USE= GNOME=gtk20
X11_USES= gnome
post-patch:
- @${REINPLACE_CMD} -e 's|getopt.*$$(OBJEXT)||g; s|getopt.*[ch]||g; /getopt.*Po/d' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|m4_esyscmd(\[build-aux/git-version-gen \.tarball-version\])|${PORTVERSION}|' ${WRKSRC}/configure.ac
- @${REINPLACE_CMD} -e 's|"getopt\.h"|<getopt.h>|g' ${WRKSRC}/ui/mtr.c
post-install:
@${ECHO_MSG} ""
diff --git a/net/mtr/distinfo b/net/mtr/distinfo
index 2e71b8d216be..a4fc4bdbecd5 100644
--- a/net/mtr/distinfo
+++ b/net/mtr/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1496491441
-SHA256 (mtr-0.92.tar.gz) = f2979db9e2f41aa8e6574e7771767c9afe111d9213814eb47f5e1e71876e4382
-SIZE (mtr-0.92.tar.gz) = 296430
+TIMESTAMP = 1578125689
+SHA256 (traviscross-mtr-v0.93_GH0.tar.gz) = 3a1ab330104ddee3135af3cfa567b9608001c5deecbf200c08b545ed6d7a4c8f
+SIZE (traviscross-mtr-v0.93_GH0.tar.gz) = 142148
diff --git a/net/mtr/files/patch-packet-probe_unix.c b/net/mtr/files/patch-packet-probe_unix.c
new file mode 100644
index 000000000000..8fd3c680a425
--- /dev/null
+++ b/net/mtr/files/patch-packet-probe_unix.c
@@ -0,0 +1,25 @@
+--- packet/probe_unix.c.orig 2019-08-03 08:31:26 UTC
++++ packet/probe_unix.c
+@@ -798,6 +798,7 @@ void receive_replies_from_recv_socket(
+ #endif
+
+ #ifdef SO_PROTOCOL
++#ifdef HAVE_LINUX_ERRQUEUE_H
+ if (icmp_connrefused_received) {
+ /* using ICMP type ICMP_ECHOREPLY is not a bug, it is an
+ indication of successfully reaching dst host.
+@@ -815,11 +816,14 @@ void receive_replies_from_recv_socket(
+ packet, packet_length, &timestamp);
+ } else {
+ #endif
++#endif
+ /* ICMP packets received from raw socket */
+ handle_received_packet(net_state, &remote_addr, packet,
+ packet_length, &timestamp);
+ #ifdef SO_PROTOCOL
++#ifdef HAVE_LINUX_ERRQUEUE_H
+ }
++#endif
+ #endif
+ }
+ }
diff --git a/net/mtr/files/patch-ui-mtr.c b/net/mtr/files/patch-ui-mtr.c
deleted file mode 100644
index 020f056294e4..000000000000
--- a/net/mtr/files/patch-ui-mtr.c
+++ /dev/null
@@ -1,12 +0,0 @@
-Obtained from: https://github.com/traviscross/mtr/commit/3649b04337d38725f58a3d8ebe7845cb7fa3cabf
-
---- ui/mtr.c.orig 2017-02-05 07:27:33 UTC
-+++ ui/mtr.c
-@@ -301,6 +301,7 @@ static void init_fld_options(
- ctl->available_options[i] = data_fields[i].key;
- ctl->fld_index[data_fields[i].key] = i;
- }
-+ ctl->available_options[i++] = '_';
- ctl->available_options[i] = 0;
- }
-