aboutsummaryrefslogtreecommitdiffstats
path: root/net/nast
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-03-20 18:53:08 +0800
committertijl <tijl@FreeBSD.org>2016-03-20 18:53:08 +0800
commit9bf09f69cf8a3acf95e51a0a1e8d6eedfd31e3ca (patch)
treec30aa05ffe4be67ca3bb38317073b7e6603daa7c /net/nast
parent6af0c041428d493f447a328f9e81efe5b6d72273 (diff)
downloadfreebsd-ports-gnome-9bf09f69cf8a3acf95e51a0a1e8d6eedfd31e3ca.tar.gz
freebsd-ports-gnome-9bf09f69cf8a3acf95e51a0a1e8d6eedfd31e3ca.tar.zst
freebsd-ports-gnome-9bf09f69cf8a3acf95e51a0a1e8d6eedfd31e3ca.zip
Install net/libnet headers and libraries back in the location where other
ports expect it. The files were put in a different location to avoid a conflict with net/libnet10 but this port has been removed a while ago now. PR: 208122 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'net/nast')
-rw-r--r--net/nast/Makefile11
-rw-r--r--net/nast/files/patch-configure85
2 files changed, 35 insertions, 61 deletions
diff --git a/net/nast/Makefile b/net/nast/Makefile
index 3227e8ddfc79..350476b49ae6 100644
--- a/net/nast/Makefile
+++ b/net/nast/Makefile
@@ -20,18 +20,11 @@ GNU_CONFIGURE= yes
PLIST_FILES= bin/nast man/man8/nast.8.gz
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-
-.include <bsd.port.pre.mk>
-
post-patch:
- @${REINPLACE_CMD} -e \
- 's|libnet-config|${LIBNET_CONFIG}|; \
- s|-lnet|`${LIBNET_CONFIG} --libs`|' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/configure
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${STAGEDIR}${MANPREFIX}/man/man8
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/nast/files/patch-configure b/net/nast/files/patch-configure
index 65a061a223c8..8eb0e27eb7cd 100644
--- a/net/nast/files/patch-configure
+++ b/net/nast/files/patch-configure
@@ -1,61 +1,42 @@
--- configure.orig 2004-01-20 18:54:58 UTC
+++ configure
-@@ -2337,52 +2337,8 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
- #
+@@ -2379,7 +2379,7 @@ fi
+ echo "$as_me:$LINENO: result: $ac_cv_file__usr_local_lib_libnet_a" >&5
+ echo "${ECHO_T}$ac_cv_file__usr_local_lib_libnet_a" >&6
+ if test $ac_cv_file__usr_local_lib_libnet_a = yes; then
+- filechk="yes" ; LDFLAGS="-L/usr/local/lib"; CPPFLAGS="-I/usr/local/include"
++ filechk="yes" ; LIBS="$LIBS -L/usr/local/lib"; CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+ fi
+
+ fi
+@@ -2530,7 +2530,7 @@ fi
+ echo "$as_me:$LINENO: result: $ac_cv_file__usr_local_lib_libpcap_a" >&5
+ echo "${ECHO_T}$ac_cv_file__usr_local_lib_libpcap_a" >&6
+ if test $ac_cv_file__usr_local_lib_libpcap_a = yes; then
+- filechk="yes" ; LDFLAGS="-L/usr/local/lib"; CPPFLAGS="-I/usr/local/include"
++ filechk="yes" ; LIBS="$LIBS -L/usr/local/lib"; CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+ fi
- filechk="yes"
--echo "$as_me:$LINENO: checking for /usr/lib/libnet.a" >&5
--echo $ECHO_N "checking for /usr/lib/libnet.a... $ECHO_C" >&6
--if test "${ac_cv_file__usr_lib_libnet_a+set}" = set; then
-- echo $ECHO_N "(cached) $ECHO_C" >&6
--else
-- test "$cross_compiling" = yes &&
-- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
--echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
-- { (exit 1); exit 1; }; }
--if test -r "/usr/lib/libnet.a"; then
-- ac_cv_file__usr_lib_libnet_a=yes
--else
-- ac_cv_file__usr_lib_libnet_a=no
--fi
--fi
--echo "$as_me:$LINENO: result: $ac_cv_file__usr_lib_libnet_a" >&5
--echo "${ECHO_T}$ac_cv_file__usr_lib_libnet_a" >&6
--if test $ac_cv_file__usr_lib_libnet_a = yes; then
-- :
--else
-- filechk="no"
--fi
--
--if test "$filechk" = "no"; then
-- echo "$as_me:$LINENO: checking for /usr/local/lib/libnet.a" >&5
--echo $ECHO_N "checking for /usr/local/lib/libnet.a... $ECHO_C" >&6
--if test "${ac_cv_file__usr_local_lib_libnet_a+set}" = set; then
-- echo $ECHO_N "(cached) $ECHO_C" >&6
--else
-- test "$cross_compiling" = yes &&
-- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
--echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
-- { (exit 1); exit 1; }; }
--if test -r "/usr/local/lib/libnet.a"; then
-- ac_cv_file__usr_local_lib_libnet_a=yes
--else
-- ac_cv_file__usr_local_lib_libnet_a=no
--fi
--fi
--echo "$as_me:$LINENO: result: $ac_cv_file__usr_local_lib_libnet_a" >&5
--echo "${ECHO_T}$ac_cv_file__usr_local_lib_libnet_a" >&6
--if test $ac_cv_file__usr_local_lib_libnet_a = yes; then
+ fi
+@@ -2680,7 +2680,7 @@ fi
+ echo "$as_me:$LINENO: result: $ac_cv_file__usr_local_lib_libncurses_a" >&5
+ echo "${ECHO_T}$ac_cv_file__usr_local_lib_libncurses_a" >&6
+ if test $ac_cv_file__usr_local_lib_libncurses_a = yes; then
- filechk="yes" ; LDFLAGS="-L/usr/local/lib"; CPPFLAGS="-I/usr/local/include"
--fi
--
--fi
-+CPPFLAGS="${CPPFLAGS} `libnet-config --cflags`"
-+LDFLAGS="${LDFLAGS} `libnet-config --libs`"
++ filechk="yes" ; LIBS="$LIBS -L/usr/local/lib"; CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+ fi
- if test "$filechk" = "no"; then { { echo "$as_me:$LINENO: error:
+ fi
+@@ -2840,7 +2840,7 @@ fi
+ echo "$as_me:$LINENO: result: $ac_cv_file__usr_local_lib_libmenu_a" >&5
+ echo "${ECHO_T}$ac_cv_file__usr_local_lib_libmenu_a" >&6
+ if test $ac_cv_file__usr_local_lib_libmenu_a = yes; then
+- filechk="yes" ; LDFLAGS="-L/usr/local/lib"; CPPFLAGS="-I/usr/local/include"
++ filechk="yes" ; LIBS="$LIBS -L/usr/local/lib"; CPPFLAGS="$CPPFLAGS -I/usr/local/include"
+ fi
-@@ -3045,8 +3001,8 @@ fi
+ fi
+@@ -3045,8 +3045,8 @@ fi
CFLAGS="-Wall -O2"
;;