aboutsummaryrefslogtreecommitdiffstats
path: root/net/ndpi/Makefile
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-12-02 16:02:31 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-12-02 16:02:31 +0800
commitfbce7606cd0c7866de8ce37bd6617994afd1d849 (patch)
treea35f5a8eef584a275d7b109b3d7b0f71076c61c2 /net/ndpi/Makefile
parentb6548ac245abee23534b56107d703ed935e7d66e (diff)
downloadfreebsd-ports-gnome-fbce7606cd0c7866de8ce37bd6617994afd1d849.tar.gz
freebsd-ports-gnome-fbce7606cd0c7866de8ce37bd6617994afd1d849.tar.zst
freebsd-ports-gnome-fbce7606cd0c7866de8ce37bd6617994afd1d849.zip
- Add ndpi 1.4.0
- While I'm here: - Use PORTVERSION - Use USES=pathfix - Use PLIST_SUB - Update WWW nDPI is a ntop-maintained superset of the popular OpenDPI library. Its goal is to extend the original library by adding new protocols that are otherwise available only on the paid version of OpenDPI. Furthermore, we have modified nDPI do be more suitable for traffic monitoring applications, by disabling specific features that slow down the DPI engine while being them un-necessary for network traffic monitoring. WWW: http://www.ntop.org/products/ndpi/ PR: ports/184209 Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com>
Diffstat (limited to 'net/ndpi/Makefile')
-rw-r--r--net/ndpi/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/net/ndpi/Makefile b/net/ndpi/Makefile
new file mode 100644
index 000000000000..0b26cb99ab8a
--- /dev/null
+++ b/net/ndpi/Makefile
@@ -0,0 +1,22 @@
+# Created by: Muhammad Moinur Rahman <5u623l20@gmail.com>
+# $FreeBSD$
+
+PORTNAME= ndpi
+PORTVERSION= 1.4.0
+CATEGORIES= net
+MASTER_SITES= SF/ntop/nDPI
+DISTNAME= nDPI-${PORTVERSION}_r7023
+
+MAINTAINER= 5u623l20@gmail.com
+COMMENT= ntop-maintained superset of the popular OpenDPI library
+
+LICENSE= GPLv3
+
+CONFIGURE_ARGS= --with-pic
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USES= pathfix pkgconfig
+
+PLIST_SUB= MAJOR_VER=${PORTVERSION:R}
+
+.include <bsd.port.mk>