aboutsummaryrefslogtreecommitdiffstats
path: root/net/neoupdate/Makefile
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2001-01-09 23:19:17 +0800
committerJames E. Housley <jeh@FreeBSD.org>2001-01-09 23:19:17 +0800
commitce0f2e976fb1279ee81522a5c57d76e98f2f6a0c (patch)
treee08f41a99f5f8867d7a7bcc8cdb1b41b9c6a52bb /net/neoupdate/Makefile
parent2530eb5439bbe92096d8cf7d0aa2d5d5857c0527 (diff)
downloadfreebsd-ports-gnome-ce0f2e976fb1279ee81522a5c57d76e98f2f6a0c.tar.gz
freebsd-ports-gnome-ce0f2e976fb1279ee81522a5c57d76e98f2f6a0c.tar.zst
freebsd-ports-gnome-ce0f2e976fb1279ee81522a5c57d76e98f2f6a0c.zip
New Port: net/neoupdate
A Perl Script to automagically update DNS at centralinfo.net or yi.org when your IP changes, both offer free DNS services.
Diffstat (limited to 'net/neoupdate/Makefile')
-rw-r--r--net/neoupdate/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/net/neoupdate/Makefile b/net/neoupdate/Makefile
new file mode 100644
index 000000000000..8cfbbd808670
--- /dev/null
+++ b/net/neoupdate/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: neoupdate
+# Date created: 9 January 2001
+# Whom: jim@thehousleys.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= neoupdate
+PORTVERSION= 1.10
+CATEGORIES= net
+MASTER_SITES= http://www.iamnewbie.com/download/
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= jeh@FreeBSD.org
+
+RUN_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_PERL= yes
+NO_BUILD= yes
+
+SITE_PERL= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}
+
+.if !defined(NOPORTDOCS)
+PLIST_SUB= NOPORTDOCS=''
+.else
+PLIST_SUB= NOPORTDOCS='@comment '
+.endif
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/neoupdate.pl ${PREFIX}/sbin
+ @${INSTALL_SCRIPT} ${WRKSRC}/ip.pl ${PREFIX}/sbin
+ @${INSTALL_SCRIPT} ${WRKSRC}/neoupdate.conf ${PREFIX}/etc
+ @${INSTALL_SCRIPT} ${WRKSRC}/yi.conf ${PREFIX}/etc
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/neoupdate
+ @${INSTALL_DATA} ${WRKSRC}/neoupdate.cron ${PREFIX}/share/doc/neoupdate
+ @${INSTALL_DATA} ${WRKSRC}/readme.txt ${PREFIX}/share/doc/neoupdate
+.endif
+ @${CAT} ${PKGMESSAGE}
+.include <bsd.port.mk>