aboutsummaryrefslogtreecommitdiffstats
path: root/net/netatalk3
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2014-01-19 06:35:41 +0800
committermarcus <marcus@FreeBSD.org>2014-01-19 06:35:41 +0800
commit1cbd63f2163c9a4ac8ad47c61295a44a6ea595da (patch)
tree9464dfb665364be746abe199f1095e313468350c /net/netatalk3
parent920553738adb891954a6add9781b1ac5417b4bf2 (diff)
downloadfreebsd-ports-gnome-1cbd63f2163c9a4ac8ad47c61295a44a6ea595da.tar.gz
freebsd-ports-gnome-1cbd63f2163c9a4ac8ad47c61295a44a6ea595da.tar.zst
freebsd-ports-gnome-1cbd63f2163c9a4ac8ad47c61295a44a6ea595da.zip
* Fix a segfault when Zeroconf is enabled with Timemachine [1]
* Convert to new-style LIB_DEPENDS PR: 185862 [1] Submitted by: jpaetzel [1]
Diffstat (limited to 'net/netatalk3')
-rw-r--r--net/netatalk3/Makefile6
-rw-r--r--net/netatalk3/files/patch-etc_afpd_afp_mdns.c34
2 files changed, 37 insertions, 3 deletions
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index f5cc06fda796..e1aa685b8ccb 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= netatalk
PORTVERSION= 3.1.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= SF
@@ -15,8 +15,8 @@ COMMENT= File server for Mac OS X
LICENSE= GPLv2
-LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt \
- event-2:${PORTSDIR}/devel/libevent2
+LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libevent-2.so:${PORTSDIR}/devel/libevent2
USE_AUTOTOOLS= libtool
USE_BDB= 46+
diff --git a/net/netatalk3/files/patch-etc_afpd_afp_mdns.c b/net/netatalk3/files/patch-etc_afpd_afp_mdns.c
new file mode 100644
index 000000000000..a457378498f0
--- /dev/null
+++ b/net/netatalk3/files/patch-etc_afpd_afp_mdns.c
@@ -0,0 +1,34 @@
+--- etc/afpd/afp_mdns.c.orig 2013-10-28 06:43:13.000000000 -0700
++++ etc/afpd/afp_mdns.c 2014-01-17 22:10:59.000000000 -0800
+@@ -37,17 +37,15 @@
+ * Its easier to use asprintf to set the TXT record values
+ */
+ #define TXTRecordPrintf(rec, key, args, ...) { \
+- char *str; \
+- asprintf(&str, args); \
++ char str[1024]; \
++ sprintf(str, args); \
+ TXTRecordSetValue(rec, key, strlen(str), str); \
+- free(str); \
+ }
+ #define TXTRecordKeyPrintf(rec, k, var, args, ...) { \
+- char *key, *str; \
+- asprintf(&key, k, var); \
+- asprintf(&str, args); \
++ char key[1024], str[1024]; \
++ sprintf(key, k, var); \
++ sprintf(str, args); \
+ TXTRecordSetValue(rec, key, strlen(str), str); \
+- free(str); free(key); \
+ }
+
+ static struct pollfd *fds;
+@@ -134,7 +132,7 @@
+
+ /* Register our service, prepare the TXT record */
+ TXTRecordCreate(&txt_adisk, 0, NULL);
+- TXTRecordPrintf(&txt_adisk, "sys", "waMa=0,adVF=0x100");
++ TXTRecordPrintf(&txt_adisk, "sys", "waMa=0,adVF=0x100", NULL);
+
+ /* Build AFP volumes list */
+ int i = 0;