aboutsummaryrefslogtreecommitdiffstats
path: root/net/ntop/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-07-03 20:36:11 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-07-03 20:36:11 +0800
commit4accd2a7b8871e76a0ea93b854fa93a21dc89ae6 (patch)
tree1811ec3ba412e18779c970861424ba47df2c2d71 /net/ntop/Makefile
parent605f41523a1d095773dddc0a4ab23f0796163094 (diff)
downloadfreebsd-ports-gnome-4accd2a7b8871e76a0ea93b854fa93a21dc89ae6.tar.gz
freebsd-ports-gnome-4accd2a7b8871e76a0ea93b854fa93a21dc89ae6.tar.zst
freebsd-ports-gnome-4accd2a7b8871e76a0ea93b854fa93a21dc89ae6.zip
- Finalize switch to libtool (remove USE_AUTOTOOLS=libtool)
- Strip all installed libraries (not stripped by install-strip target)
Diffstat (limited to 'net/ntop/Makefile')
-rw-r--r--net/ntop/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index ef34f68ef2a0..ad5683d5ae4b 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
DBDIR?= /var/db
USES= gmake libtool
-USE_AUTOTOOLS= libtool automake autoconf
+USE_AUTOTOOLS= automake autoconf libtoolize
USE_GNOME= libxml2
USE_PYTHON= yes
USE_OPENSSL= yes
@@ -85,4 +85,7 @@ pre-configure:
pre-install:
@cd ${WRKSRC} && ${MAKE_CMD} dnetter
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/ntop/plugins/*.so
+
.include <bsd.port.mk>