aboutsummaryrefslogtreecommitdiffstats
path: root/net/ntp
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2002-07-13 02:50:34 +0800
committercy <cy@FreeBSD.org>2002-07-13 02:50:34 +0800
commit4ac5d9607fc7602b3c08e5215a03c2f8e1895272 (patch)
treed654fb4f914d615c4d99cc61a30bb4bcb7e8e3fe /net/ntp
parenta82f08871f8013c917f065b2f8068be432ba5fea (diff)
downloadfreebsd-ports-gnome-4ac5d9607fc7602b3c08e5215a03c2f8e1895272.tar.gz
freebsd-ports-gnome-4ac5d9607fc7602b3c08e5215a03c2f8e1895272.tar.zst
freebsd-ports-gnome-4ac5d9607fc7602b3c08e5215a03c2f8e1895272.zip
Fix jjy driver. This patch fixes an invalid command to the
C-DEX JST2000. Submitted by: nork Reviewed by: Harlan Stenn <stenn@whimsy.udel.edu>
Diffstat (limited to 'net/ntp')
-rw-r--r--net/ntp/Makefile1
-rw-r--r--net/ntp/files/patch-ntpd::refclock_jjy.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index 2465ba3daf3b..565346189d8f 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ntp
PORTVERSION= 4.1.1a
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.udel.edu/pub/ntp/ntp4/ \
http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ \
diff --git a/net/ntp/files/patch-ntpd::refclock_jjy.c b/net/ntp/files/patch-ntpd::refclock_jjy.c
new file mode 100644
index 000000000000..4852ac012988
--- /dev/null
+++ b/net/ntp/files/patch-ntpd::refclock_jjy.c
@@ -0,0 +1,11 @@
+--- ntpd/refclock_jjy.c.orig Thu Jan 17 10:40:53 2002
++++ ntpd/refclock_jjy.c Fri Jul 12 11:37:44 2002
+@@ -701,7 +701,7 @@
+ * Send "<ENQ>1J<ETX>" command
+ */
+
+- if ( write ( pp->io.fd, "\x051J\x03", 4 ) != 4 ) {
++ if ( write ( pp->io.fd, "\0051J\003", 4 ) != 4 ) {
+ refclock_report ( peer, CEVNT_FAULT ) ;
+ }
+