aboutsummaryrefslogtreecommitdiffstats
path: root/net/ntpa
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-08-01 02:08:30 +0800
committerPawel Pekala <pawel@FreeBSD.org>2016-08-01 02:08:30 +0800
commitbf89dd70ae31bef17793d2664bb4d5086e55ff61 (patch)
tree4460a64525bbe31a47a90166149e86661ba168b3 /net/ntpa
parenta71b5042c2c22050a9a1ad85d0d5854dc72bfdfc (diff)
downloadfreebsd-ports-gnome-bf89dd70ae31bef17793d2664bb4d5086e55ff61.tar.gz
freebsd-ports-gnome-bf89dd70ae31bef17793d2664bb4d5086e55ff61.tar.zst
freebsd-ports-gnome-bf89dd70ae31bef17793d2664bb4d5086e55ff61.zip
- Change default options to include both database providers [1]
- Remove build of deselected database providers [1] - Include option depended GPLv2 license [1] - Patch error in default config file [1] - Move options declaration block to the proper place PR: 211342 [1] Submitted by: Carsten Larsen (maintainer)
Diffstat (limited to 'net/ntpa')
-rw-r--r--net/ntpa/Makefile38
-rw-r--r--net/ntpa/files/patch-examples_ntpa.conf18
2 files changed, 43 insertions, 13 deletions
diff --git a/net/ntpa/Makefile b/net/ntpa/Makefile
index 6cbac5c8e17f..537fef2877a7 100644
--- a/net/ntpa/Makefile
+++ b/net/ntpa/Makefile
@@ -3,23 +3,39 @@
PORTNAME= ntpa
PORTVERSION= 0.6.2
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://suyai.innolan.net/
MAINTAINER= cs@innolan.dk
COMMENT= NTP data collection and charting
-LICENSE= MIT
+LICENSE= MIT GPLv2+
+LICENSE_COMB= dual
+LICENSE_FILE_GPLv2+ = ${WRKSRC}/MySql/COPYING
+
+USES= mono
+NO_ARCH= yes
+HAS_CONFIGURE= yes
+OPTIONS_SUB= yes
+USE_RC_SUBR= ntpa
+
+USERS= ntpa
+GROUPS= ntpa
+
+SUB_FILES= ntpad ntpav ntpac
+WRKSRC= ${WRKDIR}/anguist-ntpa-9204e1e36b8d
OPTIONS_DEFINE= WEBFILES GRAPH
-OPTIONS_DEFAULT= PGSQL
+OPTIONS_DEFAULT= PGSQL MYSQL
OPTIONS_MULTI= DATABASE
OPTIONS_MULTI_DATABASE= PGSQL MYSQL
+
WEBFILES_IMPLIES= GRAPH
WEBFILES_DESC= Install web files
GRAPH_DESC= Graph generation (requires Cairo)
PGSQL_DESC= PostgreSQL Connector
-MYSQL_DESC= MySQL Connector (GPL)
+MYSQL_DESC= MySQL Connector (GPLv2)
DATABASE_DESC= Database provider
GRAPH_LIB_DEPENDS= libgdiplus.so:x11-toolkits/libgdiplus \
@@ -30,17 +46,13 @@ GRAPH_CONFIGURE_ON= GRAPH
MYSQL_CONFIGURE_ON= MYSQL
PGSQL_CONFIGURE_ON= PGSQL
-USES= mono
-NO_ARCH= yes
-HAS_CONFIGURE= yes
-OPTIONS_SUB= yes
-USE_RC_SUBR= ntpa
+do-patch-MYSQL-off:
+ @${REINPLACE_CMD} '/E9DF5ED1-4CBD-4226-B931-9A51610AC14D/,+1 d' \
+ ${WRKSRC}/Ntp.Analyzer.sln
-USERS= ntpa
-GROUPS= ntpa
-
-SUB_FILES= ntpad ntpav ntpac
-WRKSRC= ${WRKDIR}/anguist-ntpa-9204e1e36b8d
+do-patch-PGSQL-off:
+ @${REINPLACE_CMD} '/9D13B739-62B1-4190-B386-7A9547304EB3/,+1 d' \
+ ${WRKSRC}/Ntp.Analyzer.sln
pre-install:
@${MKDIR} ${WRKSRC}/script
diff --git a/net/ntpa/files/patch-examples_ntpa.conf b/net/ntpa/files/patch-examples_ntpa.conf
new file mode 100644
index 000000000000..a1df6a2c81ed
--- /dev/null
+++ b/net/ntpa/files/patch-examples_ntpa.conf
@@ -0,0 +1,18 @@
+--- examples/ntpa.conf.orig 2016-07-24 15:58:08 UTC
++++ examples/ntpa.conf
+@@ -152,6 +152,8 @@ Server {
+ Destinations {
+ File about.html
+ }
++
++ Link about.html
+ }
+
+ ############### Bootstrap menu ##############
+@@ -289,4 +291,4 @@ Server {
+ Link peers/delay-
+ }
+ }
+-}
+\ No newline at end of file
++}