aboutsummaryrefslogtreecommitdiffstats
path: root/net/opal/Makefile
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-05 10:44:55 +0800
committerclsung <clsung@FreeBSD.org>2006-07-05 10:44:55 +0800
commit5af64df15fb0324ebe42f253c6417a9cc97827d3 (patch)
treee5784a65d02d9546a73ce0538748a2c73695d349 /net/opal/Makefile
parent0ac69c432c3130115c05b45e6c8cea3af894c7fe (diff)
downloadfreebsd-ports-gnome-5af64df15fb0324ebe42f253c6417a9cc97827d3.tar.gz
freebsd-ports-gnome-5af64df15fb0324ebe42f253c6417a9cc97827d3.tar.zst
freebsd-ports-gnome-5af64df15fb0324ebe42f253c6417a9cc97827d3.zip
- update to 2.2.2
- This is an update of net/ekiga and net/opal. Requires the latest update to pwlib (FreeBSD port is uptodate since one week). This update also incorporates a new user-contributed patch, see Bug 345308 - Keypad does not work properly at http://bugzilla.gnome.org/show_bug.cgi?id=345308 PR: ports/99764 Submitted by: maintainer (Jean-Baptiste Quenot)
Diffstat (limited to 'net/opal/Makefile')
-rw-r--r--net/opal/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/net/opal/Makefile b/net/opal/Makefile
index 8a691c50ee98..bd674cebb606 100644
--- a/net/opal/Makefile
+++ b/net/opal/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= opal
-PORTVERSION= 2.2.1
-PORTREVISION= 1
+PORTVERSION= 2.2.2
CATEGORIES= net
MASTER_SITES= http://www.voxgratia.org/releases/
DISTNAME= ${PORTNAME}-v${PORTVERSION:S/./_/g}-src-
@@ -18,7 +17,7 @@ COMMENT= VoIP abstraction library
LIB_DEPENDS= pt_r.1:${PORTSDIR}/devel/pwlib
-WRKSRC= ${WRKDIR}/${PORTNAME}_v${PORTVERSION:S/./_/g}
+WRKSRC= ${WRKDIR}/${PORTNAME}_Phobos_release2
# In opal's Makefile the default make's target is optshared
ALL_TARGET= optshared
@@ -30,6 +29,7 @@ NO_FILTER_SHLIBS= yes
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+PLIST_SUB= PORTVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
@@ -37,8 +37,8 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include
BROKEN= Does not build on FreeBSD 4.x, if you manage to make it work, please send a patch to the maintainer: ${MAINTAINER}
.endif
-# Avoid build error on amd64: relocation R_X86_64_32 can not be used when making a shared object; recompile with -fPIC
-.if (${ARCH} == "amd64")
+# Avoid build error on 64-bit architectures
+.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
CFLAGS+= -fPIC
.endif