aboutsummaryrefslogtreecommitdiffstats
path: root/net/openbgpd
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2013-10-17 14:19:25 +0800
committerhrs <hrs@FreeBSD.org>2013-10-17 14:19:25 +0800
commit499d68f21364531b236157db17282eeaf4de8bea (patch)
treec461b4675517476bc90dd1eac33d3eb7653abb1c /net/openbgpd
parent8bc917ba8e7016784359f600038fae532ab3183b (diff)
downloadfreebsd-ports-gnome-499d68f21364531b236157db17282eeaf4de8bea.tar.gz
freebsd-ports-gnome-499d68f21364531b236157db17282eeaf4de8bea.tar.zst
freebsd-ports-gnome-499d68f21364531b236157db17282eeaf4de8bea.zip
Add STAGEDIR support.
Diffstat (limited to 'net/openbgpd')
-rw-r--r--net/openbgpd/Makefile29
1 files changed, 9 insertions, 20 deletions
diff --git a/net/openbgpd/Makefile b/net/openbgpd/Makefile
index 4cd853d70998..a3fd6a265759 100644
--- a/net/openbgpd/Makefile
+++ b/net/openbgpd/Makefile
@@ -14,29 +14,21 @@ COMMENT= Free implementation of the Border Gateway Protocol, Version 4
CONFLICTS= zebra-[0-9]* quagga-[0-9]*
-OPTIONS_DEFINE= IPV6LLPEER
-OPTIONS_DEFAULT=IPV6LLPEER
-IPV6LLPEER_DESC=Support nexthop using IPv6 link-local address
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BROKEN= does not build
-.endif
-
WRKSRC= ${WRKDIR}
-MANCOMPRESSED= yes
USE_RC_SUBR= ${PORTNAME}
-PLIST_FILES= sbin/bgpctl sbin/bgpd
+PLIST_FILES= sbin/bgpctl sbin/bgpd man/man5/bgpd.conf.5.gz \
+ man/man8/bgpctl.8.gz man/man8/bgpd.8.gz
SUB_FILES= pkg-message
USERS= _bgpd
GROUPS= _bgpd
-MAN5= bgpd.conf.5
-MAN8= bgpctl.8 bgpd.8
+OPTIONS_DEFINE= IPV6LLPEER
+OPTIONS_DEFAULT=IPV6LLPEER
+IPV6LLPEER_DESC=Support nexthop using IPv6 link-local address
+
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_IPV6LLPEER)
+.if ${PORT_OPTIONS:MIPV6LLPEER)
MAKE_ARGS= -DIPV6_LINKLOCAL_PEER
.endif
@@ -46,7 +38,4 @@ post-patch:
${WRKSRC}/bgpd/bgpd.conf.5 \
${WRKSRC}/bgpctl/bgpctl.8
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>