aboutsummaryrefslogtreecommitdiffstats
path: root/net/openldap2/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2001-05-13 04:14:35 +0800
committerJimmy Olgeni <olgeni@FreeBSD.org>2001-05-13 04:14:35 +0800
commit604c0d03b4243e9fe8345cd7738adf2f0febc7f9 (patch)
treecd97a7772b5d2a3950691842369398209927b19b /net/openldap2/Makefile
parent5aed59a2955b1a486681de3ee8b712ded8e837c8 (diff)
downloadfreebsd-ports-gnome-604c0d03b4243e9fe8345cd7738adf2f0febc7f9.tar.gz
freebsd-ports-gnome-604c0d03b4243e9fe8345cd7738adf2f0febc7f9.tar.zst
freebsd-ports-gnome-604c0d03b4243e9fe8345cd7738adf2f0febc7f9.zip
Update port to version 2.0.8.
* Rewrite lines like: @exec [ CONDITION ] && ACTION as: @exec [ ! CONDITION ] || ACTION In the first version, the @executed command returns false if CONDITION is false and ACTION is not performed: pkg_add would then complain about the whole command's exit code. The second version returns either true or the actual ACTION exit code. * Do not echo some Makefile commands.
Diffstat (limited to 'net/openldap2/Makefile')
-rw-r--r--net/openldap2/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/net/openldap2/Makefile b/net/openldap2/Makefile
index bb2b25ab301a..0dde938e88ef 100644
--- a/net/openldap2/Makefile
+++ b/net/openldap2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 2.0.7
-PORTREVISION= 1
+PORTVERSION= 2.0.8
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.net.lut.ac.uk/openldap/%SUBDIR%/ \
@@ -78,19 +77,19 @@ BINS= bin/ldapadd \
.include "${FILESDIR}/manpages"
post-configure:
- cd ${WRKSRC} ; ${PATCH} < ${FILESDIR}/libtool.diff
+ @cd ${WRKSRC} ; ${PATCH} < ${FILESDIR}/libtool.diff
pre-build:
- cd ${WRKSRC} ; ${MAKE} depend
+ @cd ${WRKSRC} ; ${MAKE} depend
post-build:
- ${SED} 's,@@PREFIX@@,${PREFIX},g' ${FILESDIR}/slapd.sh >${WRKDIR}/slapd.sh
+ @${SED} 's,@@PREFIX@@,${PREFIX},g' ${FILESDIR}/slapd.sh >${WRKDIR}/slapd.sh
post-install:
.for f in ${BINS}
- strip ${PREFIX}/${f}
+ @strip ${PREFIX}/${f}
.endfor
- ${INSTALL_SCRIPT} ${WRKDIR}/slapd.sh ${PREFIX}/etc/rc.d/slapd.sh.sample
+ @${INSTALL_SCRIPT} ${WRKDIR}/slapd.sh ${PREFIX}/etc/rc.d/slapd.sh.sample
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>