aboutsummaryrefslogtreecommitdiffstats
path: root/net/openldap22-server
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-07-07 13:39:01 +0800
committerdaichi <daichi@FreeBSD.org>2003-07-07 13:39:01 +0800
commit0a3de141a15047e4e19a59c9edea92c87a36b060 (patch)
tree606a2d98ed1c555b2167e2f09c6276812c12cc08 /net/openldap22-server
parentdc41e56597b66c11524ffacd48f4f65708dcd639 (diff)
downloadfreebsd-ports-gnome-0a3de141a15047e4e19a59c9edea92c87a36b060.tar.gz
freebsd-ports-gnome-0a3de141a15047e4e19a59c9edea92c87a36b060.tar.zst
freebsd-ports-gnome-0a3de141a15047e4e19a59c9edea92c87a36b060.zip
fix net/openldap22:
- fix warnings and potential crash on 64 bit platforms PR: 54122 Submitted by: Oliver Eikemeier <eikemeier@fillmore-labs.com> (maintainer)
Diffstat (limited to 'net/openldap22-server')
-rw-r--r--net/openldap22-server/Makefile3
-rw-r--r--net/openldap22-server/files/patch-libraries::liblunicode::ucstr.c11
2 files changed, 13 insertions, 1 deletions
diff --git a/net/openldap22-server/Makefile b/net/openldap22-server/Makefile
index 5b6c9d83f226..bccf8e39955d 100644
--- a/net/openldap22-server/Makefile
+++ b/net/openldap22-server/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openldap
PORTVERSION= ${OPENLDAP_VERSION}.a
+PORTREVISION= 1
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
http://public.planetmirror.com/pub/openldap/%SUBDIR%/ \
@@ -18,7 +19,7 @@ MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.holywar.net/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.nl.uu.net/pub/unix/db/openldap/%SUBDIR%/ \
ftp://ftp.linux.pt/pub/mirrors/OpenLDAP/%SUBDIR%/ \
- ftp://ftp.si.uniovi.es/mirror/OpenLDAP/%SUBDIR%/ \
+ ftp://ftp.rediris.es/mirror/OpenLDAP/%SUBDIR%/ \
ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/%SUBDIR%/ \
http://openldap.cdpa.nsysu.edu.tw/OpenLDAP/%SUBDIR%/ \
ftp://ftp.u-aizu.ac.jp/pub/net/openldap/%SUBDIR%/ \
diff --git a/net/openldap22-server/files/patch-libraries::liblunicode::ucstr.c b/net/openldap22-server/files/patch-libraries::liblunicode::ucstr.c
new file mode 100644
index 000000000000..f1074e1fe6d8
--- /dev/null
+++ b/net/openldap22-server/files/patch-libraries::liblunicode::ucstr.c
@@ -0,0 +1,11 @@
+--- libraries/liblunicode/ucstr.c.orig Fri Apr 11 03:57:10 2003
++++ libraries/liblunicode/ucstr.c Sat Jul 5 10:53:04 2003
+@@ -15,6 +15,8 @@
+ #include <ldap_utf8.h>
+ #include <ldap_pvt_uc.h>
+
++#include "lber_pvt.h"
++
+ #define malloc(x) ber_memalloc_x(x,ctx)
+ #define realloc(x,y) ber_memrealloc_x(x,y,ctx)
+ #define free(x) ber_memfree_x(x,ctx)