aboutsummaryrefslogtreecommitdiffstats
path: root/net/openldap24-server/Makefile
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2001-05-13 04:14:35 +0800
committerolgeni <olgeni@FreeBSD.org>2001-05-13 04:14:35 +0800
commit2f367f4dfe66ce5b4aeb8cf3b6e6cb5fa35eb591 (patch)
tree9003f9676d84e04668523b74ff89d3434d34979c /net/openldap24-server/Makefile
parent83572ed5102a5859ae867ca69cc40662c6690f94 (diff)
downloadfreebsd-ports-gnome-2f367f4dfe66ce5b4aeb8cf3b6e6cb5fa35eb591.tar.gz
freebsd-ports-gnome-2f367f4dfe66ce5b4aeb8cf3b6e6cb5fa35eb591.tar.zst
freebsd-ports-gnome-2f367f4dfe66ce5b4aeb8cf3b6e6cb5fa35eb591.zip
Update port to version 2.0.8.
* Rewrite lines like: @exec [ CONDITION ] && ACTION as: @exec [ ! CONDITION ] || ACTION In the first version, the @executed command returns false if CONDITION is false and ACTION is not performed: pkg_add would then complain about the whole command's exit code. The second version returns either true or the actual ACTION exit code. * Do not echo some Makefile commands.
Diffstat (limited to 'net/openldap24-server/Makefile')
-rw-r--r--net/openldap24-server/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index bb2b25ab301a..0dde938e88ef 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 2.0.7
-PORTREVISION= 1
+PORTVERSION= 2.0.8
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.net.lut.ac.uk/openldap/%SUBDIR%/ \
@@ -78,19 +77,19 @@ BINS= bin/ldapadd \
.include "${FILESDIR}/manpages"
post-configure:
- cd ${WRKSRC} ; ${PATCH} < ${FILESDIR}/libtool.diff
+ @cd ${WRKSRC} ; ${PATCH} < ${FILESDIR}/libtool.diff
pre-build:
- cd ${WRKSRC} ; ${MAKE} depend
+ @cd ${WRKSRC} ; ${MAKE} depend
post-build:
- ${SED} 's,@@PREFIX@@,${PREFIX},g' ${FILESDIR}/slapd.sh >${WRKDIR}/slapd.sh
+ @${SED} 's,@@PREFIX@@,${PREFIX},g' ${FILESDIR}/slapd.sh >${WRKDIR}/slapd.sh
post-install:
.for f in ${BINS}
- strip ${PREFIX}/${f}
+ @strip ${PREFIX}/${f}
.endfor
- ${INSTALL_SCRIPT} ${WRKDIR}/slapd.sh ${PREFIX}/etc/rc.d/slapd.sh.sample
+ @${INSTALL_SCRIPT} ${WRKDIR}/slapd.sh ${PREFIX}/etc/rc.d/slapd.sh.sample
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>