aboutsummaryrefslogtreecommitdiffstats
path: root/net/openldap24-server
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2015-04-01 09:02:17 +0800
committerdelphij <delphij@FreeBSD.org>2015-04-01 09:02:17 +0800
commit0bc1facd8a4611f94411d71354fd6de6666af512 (patch)
tree7d71930b6e66c6d400808705f30b282c19575cfe /net/openldap24-server
parentd79c9bc5bda876e1b1a25ec50eac2b7afba414cc (diff)
downloadfreebsd-ports-gnome-0bc1facd8a4611f94411d71354fd6de6666af512.tar.gz
freebsd-ports-gnome-0bc1facd8a4611f94411d71354fd6de6666af512.tar.zst
freebsd-ports-gnome-0bc1facd8a4611f94411d71354fd6de6666af512.zip
Add a patch to improve Outlook interoperability at expense of possible
RFC violation. This patch is optional and not enabled by default. For detailed discussion please follow: http://www.openldap.org/lists/openldap-technical/201211/msg00175.html Requested by: Tim Gustafson <tjg ucsc edu>
Diffstat (limited to 'net/openldap24-server')
-rw-r--r--net/openldap24-server/Makefile11
-rw-r--r--net/openldap24-server/files/extrapatch-outlook-servers__slapd__schema_prep.c15
2 files changed, 25 insertions, 1 deletions
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index b299534f7555..808d5b31de2d 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -59,7 +59,7 @@ BROKEN= incompatible OpenLDAP version: ${WANT_OPENLDAP_VER}
.endif
PORTREVISION_CLIENT= 1
-PORTREVISION_SERVER= 3
+PORTREVISION_SERVER= 4
OPENLDAP_SHLIB_MAJOR= 2
OPENLDAP_SHLIB_MINOR= 10.3
OPENLDAP_MAJOR= ${DISTVERSION:R}
@@ -77,6 +77,7 @@ OPTIONS_DEFINE+= DEREF DYNGROUP DYNLIST MEMBEROF PPOLICY PROXYCACHE
OPTIONS_DEFINE+= REFINT RETCODE RWM SEQMOD SSSVLV SYNCPROV TRANSLUCENT
OPTIONS_DEFINE+= UNIQUE VALSORT SMBPWD SHA2 DYNAMIC_BACKENDS SASL
OPTIONS_DEFINE+= LMPASSWD
+OPTIONS_DEFINE+= OUTLOOK
OPTIONS_DEFAULT= MDB SYNCPROV DYNAMIC_BACKENDS
@@ -120,6 +121,7 @@ SMBPWD_DESC= With Samba Password hashes overlay
SHA2_DESC= With SHA2 Password hashes overlay
LMPASSWD_DESC= With LM hash password support (DEPRECATED)
DYNAMIC_BACKENDS_DESC= Build dynamic backends
+OUTLOOK_DESC= Force caseIgnoreOrderingMatch on name attribute (experimental)
.endif
.if defined(CLIENT_ONLY)
@@ -473,6 +475,13 @@ LIB_DEPENDS+= libslp.so:${PORTSDIR}/net/openslp
CONFIGURE_ARGS+= --enable-wrappers
.endif
+# Force using caseIgnoreOrderingMatch on 'name' attribute.
+# This may be a violation of RFC 4519 2.18 definition.
+# See http://www.openldap.org/lists/openldap-technical/201211/msg00175.html
+.if ${PORT_OPTIONS:MOUTLOOK}
+EXTRA_PATCHES+= ${FILESDIR}/extrapatch-outlook-servers__slapd__schema_prep.c
+.endif
+
# end of client/server specific configuration
.endif
diff --git a/net/openldap24-server/files/extrapatch-outlook-servers__slapd__schema_prep.c b/net/openldap24-server/files/extrapatch-outlook-servers__slapd__schema_prep.c
new file mode 100644
index 000000000000..508bc5be8202
--- /dev/null
+++ b/net/openldap24-server/files/extrapatch-outlook-servers__slapd__schema_prep.c
@@ -0,0 +1,15 @@
+#
+# This patch is obtained from:
+#
+# http://www.openldap.org/lists/openldap-technical/201212/msg00055.html
+#
+--- servers/slapd/schema_prep.c.orig 2014-09-18 18:48:49.000000000 -0700
++++ servers/slapd/schema_prep.c 2015-03-31 17:26:23.439844478 -0700
+@@ -908,6 +908,7 @@
+ "DESC 'RFC4519: common supertype of name attributes' "
+ "EQUALITY caseIgnoreMatch "
+ "SUBSTR caseIgnoreSubstringsMatch "
++ "ORDERING caseIgnoreOrderingMatch "
+ "SYNTAX 1.3.6.1.4.1.1466.115.121.1.15{32768} )",
+ NULL, SLAP_AT_ABSTRACT,
+ NULL, NULL,