aboutsummaryrefslogtreecommitdiffstats
path: root/net/openldap
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-10-31 03:08:35 +0800
committerknu <knu@FreeBSD.org>2000-10-31 03:08:35 +0800
commit67ff125855b9d6d3a82edab3ea64f9862018c45d (patch)
tree47f6279a96502b8c37d9577ae1f8354f2a347701 /net/openldap
parent3dec104a859f94829742aeef349766ee35004632 (diff)
downloadfreebsd-ports-gnome-67ff125855b9d6d3a82edab3ea64f9862018c45d.tar.gz
freebsd-ports-gnome-67ff125855b9d6d3a82edab3ea64f9862018c45d.tar.zst
freebsd-ports-gnome-67ff125855b9d6d3a82edab3ea64f9862018c45d.zip
Cosmetic.
Diffstat (limited to 'net/openldap')
-rw-r--r--net/openldap/Makefile54
1 files changed, 30 insertions, 24 deletions
diff --git a/net/openldap/Makefile b/net/openldap/Makefile
index 157ced384e46..5cdce9acb1a8 100644
--- a/net/openldap/Makefile
+++ b/net/openldap/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: openldap
-# Date created: 20 Sep 1998
-# Whom: Lachlan O'Dea
+# New ports collection makefile for: OpenLDAP 1.x
+# Date created: 20 Sep 1998
+# Whom: Lachlan O'Dea
#
# $FreeBSD$
#
@@ -9,37 +9,45 @@ PORTNAME= openldap
PORTVERSION= 1.2.11
PORTREVISION= 1
CATEGORIES= net databases
-MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/ \
- ftp://ftp.net.lut.ac.uk/openldap/openldap-release/ \
- ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/openldap-release/ \
- ftp://mirror.aarnet.edu.au/pub/OpenLDAP/openldap-release/ \
- ftp://gd.tuwien.ac.at/infosys/network/OpenLDAP/openldap-release/ \
- http://www.unibase.cz/ldapcz/Programy/Free/OpenLDAP/openldap-release/ \
- ftp://ftp.ntua.gr/mirror/OpenLDAP/openldap-release/ \
- ftp://ftp.loxinfo.co.th/pub/unix/LDAP/OpenLDAP/openldap-release/\
- ftp://ftp.zcu.cz/pub/network/openldap/openldap-release/
+MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
+ ftp://ftp.net.lut.ac.uk/openldap/%SUBDIR%/ \
+ ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/%SUBDIR%/ \
+ ftp://mirror.aarnet.edu.au/pub/OpenLDAP/%SUBDIR%/ \
+ ftp://gd.tuwien.ac.at/infosys/network/OpenLDAP/%SUBDIR%/ \
+ http://www.unibase.cz/ldapcz/Programy/Free/OpenLDAP/%SUBDIR%/ \
+ ftp://ftp.ntua.gr/mirror/OpenLDAP/%SUBDIR%/ \
+ ftp://ftp.loxinfo.co.th/pub/unix/LDAP/OpenLDAP/%SUBDIR%/ \
+ ftp://ftp.zcu.cz/pub/network/openldap/%SUBDIR%/
+MASTER_SITE_SUBDIR= openldap-release
EXTRACT_SUFX= .tgz
MAINTAINER= lodea@vet.com.au
-.if defined(WITH_DB2)
-BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
- LDFLAGS=-L${LOCALBASE}/lib
-CONFIGURE_ARGS+= --enable-ldbm --with-ldbm-api=db2
-.endif
-
USE_LIBTOOL= yes
-CONFIGURE_ARGS+= --localstatedir=/var/run --enable-shared --enable-dns
+
+CONFIGURE_ARGS= --localstatedir=/var/run \
+ --enable-shared \
+ --enable-dns
# Include tcp-wrapper support
.if exists(/usr/include/tcpd.h)
-CONFIGURE_ARGS+= --enable-wrappers
+CONFIGURE_ARGS+= --enable-wrappers
+.endif
+
+.if defined(WITH_DB2)
+BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+= --enable-ldbm \
+ --with-ldbm-api=db2
.endif
BINS= bin/ldapadd \
bin/ldapdelete \
+ bin/ldapmodify \
bin/ldapmodrdn \
+ bin/ldappasswd \
bin/ldapsearch \
bin/ud \
libexec/fax500 \
@@ -58,9 +66,7 @@ BINS= bin/ldapadd \
sbin/ldif2id2children \
sbin/ldif2id2entry \
sbin/ldif2index \
- sbin/ldif2ldbm \
- bin/ldapmodify \
- bin/ldappasswd
+ sbin/ldif2ldbm
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"