aboutsummaryrefslogtreecommitdiffstats
path: root/net/openmpi2
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2018-09-26 06:22:37 +0800
committerdanilo <danilo@FreeBSD.org>2018-09-26 06:22:37 +0800
commita83430410d92190ae71409eeb85ba3967e13d40f (patch)
treeb739b325dcffaef457d9704d6c0bcd27edf47064 /net/openmpi2
parent162b1c367dd1ce71c96d09b14f66ca0b74e48d8b (diff)
downloadfreebsd-ports-gnome-a83430410d92190ae71409eeb85ba3967e13d40f.tar.gz
freebsd-ports-gnome-a83430410d92190ae71409eeb85ba3967e13d40f.tar.zst
freebsd-ports-gnome-a83430410d92190ae71409eeb85ba3967e13d40f.zip
- Remove --enable-heterogeneous from CONFIGURE_ARGS, this option is broken and causing problems
see https://github.com/open-mpi/ompi/blob/master/README#L1387 while here - Bump PORTREVISION - Move USES to the proper section to make portlint happy PR: 231697 Submitted by: russo AT bogodyn.org
Diffstat (limited to 'net/openmpi2')
-rw-r--r--net/openmpi2/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/net/openmpi2/Makefile b/net/openmpi2/Makefile
index 230444170b26..6ddafb167855 100644
--- a/net/openmpi2/Makefile
+++ b/net/openmpi2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= openmpi
PORTVERSION= 2.1.5
+PORTREVISION= 1
CATEGORIES= net parallel
MASTER_SITES= http://www.open-mpi.org/software/ompi/v${PORTVERSION:R}/downloads/
PKGNAMESUFFIX= 2
@@ -22,11 +23,12 @@ LIB_DEPENDS= libhwloc.so:devel/hwloc \
libevent.so:devel/libevent \
libmunge.so:security/munge
-HAS_CONFIGURE= yes
-INSTALL_TARGET= install-strip
# :keepla because port uses lt_dlopen
USES= fortran gmake libtool:keepla localbase perl5 \
pkgconfig tar:bzip2
+
+HAS_CONFIGURE= yes
+INSTALL_TARGET= install-strip
USE_PERL5= build
MPIBASE?= mpi
@@ -43,7 +45,6 @@ CONFIGURE_ARGS+= --prefix=${PREFIX}/${MPIDIR} \
--enable-mpi-fortran=usempi \
--enable-mpi-cxx \
--enable-cxx-exceptions \
- --enable-heterogeneous \
--enable-mpi-thread-multiple \
--with-libevent=external \
--enable-mca-no-build=verbs,btl_openib,oob_ud \