aboutsummaryrefslogtreecommitdiffstats
path: root/net/openmpi
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2006-03-16 06:25:06 +0800
committerBrooks Davis <brooks@FreeBSD.org>2006-03-16 06:25:06 +0800
commitf43a83dbb2b4784eb68b59d0e8b05901056b5d97 (patch)
tree5c1a50707a8534421f8046617911f2148b7dad84 /net/openmpi
parent07395416833ba93037dce38f946ed36ecb2b1e5c (diff)
downloadfreebsd-ports-gnome-f43a83dbb2b4784eb68b59d0e8b05901056b5d97.tar.gz
freebsd-ports-gnome-f43a83dbb2b4784eb68b59d0e8b05901056b5d97.tar.zst
freebsd-ports-gnome-f43a83dbb2b4784eb68b59d0e8b05901056b5d97.zip
Use our sys/tree.h and it's requirements rather than some old incompatable
ones in the OpenMPI source tree. This fixes the build on 7.0. Bump PORTVERSION on all platforms as this may change the compiled output on others. Unquote BROKEN in the missing stdint.h case.
Diffstat (limited to 'net/openmpi')
-rw-r--r--net/openmpi/Makefile10
-rw-r--r--net/openmpi/files/patch-opal_event_Makefile.in15
2 files changed, 17 insertions, 8 deletions
diff --git a/net/openmpi/Makefile b/net/openmpi/Makefile
index 90beeff5a340..438b27755276 100644
--- a/net/openmpi/Makefile
+++ b/net/openmpi/Makefile
@@ -11,6 +11,7 @@
PORTNAME= openmpi
DISTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= net parallel
MASTER_SITES= http://www.open-mpi.org/software/ompi/v1.0/downloads/
@@ -22,9 +23,6 @@ LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
USE_BZIP2= yes
HAS_CONFIGURE= yes
USE_GMAKE= yes
-# Can't use until does not imply GNU_CONFIGURE or there's a sane way
-# to change the prefix for configure.
-#USE_AUTOTOOLS= libtool:15
MPIBASE?= mpi
MPIDIR?= ${MPIBASE}/${UNIQUENAME}
@@ -41,17 +39,13 @@ CONFIGURE_ARGS+= --prefix=${PREFIX}/${MPIDIR} ${CONFIGURE_TARGET}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 700000
-BROKEN= Does not compile on FreeBSD >= 7.0
-.endif
-
.if ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64
.endif
.if ${OSVERSION} < 503000
.if !exists(/usr/include/stdint.h)
-BROKEN= "requires stdint.h"
+BROKEN= requires stdint.h
.else
IGNORE= is not supported for FreeBSD < 5.3
.endif
diff --git a/net/openmpi/files/patch-opal_event_Makefile.in b/net/openmpi/files/patch-opal_event_Makefile.in
new file mode 100644
index 000000000000..5bc5c4c6e2a0
--- /dev/null
+++ b/net/openmpi/files/patch-opal_event_Makefile.in
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- opal/event/Makefile.in.orig
++++ opal/event/Makefile.in
+@@ -828,8 +828,7 @@
+ # Also specify where we can find this package's config.h because some
+ # of the header files in this directory get included elsewhere in OMPI.
+ # #@%@#$...
+-AM_CPPFLAGS = \
+- -I$(top_srcdir)/opal/event/compat
++AM_CPPFLAGS =
+
+
+ # OMPI: No need to build the sample or test