aboutsummaryrefslogtreecommitdiffstats
path: root/net/openpgm
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2015-01-21 17:10:20 +0800
committerrm <rm@FreeBSD.org>2015-01-21 17:10:20 +0800
commit4e9924d68d72fb2b7b184fce0a4097d79e51d913 (patch)
tree4a1dabd86b0ec0279323b94610d3f59b24dc73f2 /net/openpgm
parentf37ef0a53bb01e6d7b14b0da23a4c847ec00035f (diff)
downloadfreebsd-ports-gnome-4e9924d68d72fb2b7b184fce0a4097d79e51d913.tar.gz
freebsd-ports-gnome-4e9924d68d72fb2b7b184fce0a4097d79e51d913.tar.zst
freebsd-ports-gnome-4e9924d68d72fb2b7b184fce0a4097d79e51d913.zip
net/openpgm: fix build with python3
- fix build with python3 (trivial change) - clarify license (it's LGPL21+) and add LICENSE_FILE - simplify docs and examples installation - whitespace fixes - bump PORTREVISION because default package changed - examples now installed to EXAMPLESDIR instead of EXAMPLESDIR/examples) Approved by: vg (maintainer)
Diffstat (limited to 'net/openpgm')
-rw-r--r--net/openpgm/Makefile20
-rw-r--r--net/openpgm/files/patch-version__generator.py19
-rw-r--r--net/openpgm/pkg-descr4
-rw-r--r--net/openpgm/pkg-plist27
4 files changed, 31 insertions, 39 deletions
diff --git a/net/openpgm/Makefile b/net/openpgm/Makefile
index 8bf1e7476a95..a0e551275a07 100644
--- a/net/openpgm/Makefile
+++ b/net/openpgm/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openpgm
PORTVERSION= 5.2.122
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net devel
MASTER_SITES= GOOGLE_CODE
DISTNAME= libpgm-${PORTVERSION}
@@ -11,23 +11,23 @@ DISTNAME= libpgm-${PORTVERSION}
MAINTAINER= vg@FreeBSD.org
COMMENT= Implementation of the PGM reliable multicast protocol
-LICENSE= LGPL3
+LICENSE= LGPL21 # and newer
+LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-USES= pathfix perl5 tar:bzip2 libtool python:2,build
+USES= pathfix perl5 tar:bzip2 libtool python:build
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/openpgm/pgm
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= DOCS EXAMPLES
-DOCS_DESC= Install documetation
-EXAMPLES_DESC= Install examples
+PORTDOCS= draft-ietf-rmt-bb-pgmcc-03.txt rfc3208.txt
+PORTEXAMPLES= *
post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/../doc/draft-ietf-rmt-bb-pgmcc-03.txt ${STAGEDIR}${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/../doc/rfc3208.txt ${STAGEDIR}${DOCSDIR}
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} examples ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/../doc/,} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>
diff --git a/net/openpgm/files/patch-version__generator.py b/net/openpgm/files/patch-version__generator.py
new file mode 100644
index 000000000000..28fc951d2e4f
--- /dev/null
+++ b/net/openpgm/files/patch-version__generator.py
@@ -0,0 +1,19 @@
+--- version_generator.py.orig 2012-12-04 02:57:22 UTC
++++ version_generator.py
+@@ -8,7 +8,7 @@ build_date = time.strftime ("%Y-%m-%d")
+ build_time = time.strftime ("%H:%M:%S")
+ build_rev = filter (str.isdigit, "$Revision: 1487 $")
+
+-print """
++print("""
+ /* vim:ts=8:sts=8:sw=4:noai:noexpandtab
+ *
+ * OpenPGM version.
+@@ -50,6 +50,6 @@ const char* pgm_build_revision = "%s";
+
+
+ /* eof */
+-"""%(build_date, build_time, platform.system(), platform.machine(), build_rev)
++"""%(build_date, build_time, platform.system(), platform.machine(), build_rev))
+
+ # end of file
diff --git a/net/openpgm/pkg-descr b/net/openpgm/pkg-descr
index d97cf386f17a..88bb0602edf5 100644
--- a/net/openpgm/pkg-descr
+++ b/net/openpgm/pkg-descr
@@ -6,12 +6,12 @@ PGM is a receiver-reliable protocol, which means the receiver is responsible
for ensuring all data is received, absolving the sender of reception
responsibility. PGM runs over a best effort datagram service, currently OpenPGM
uses IP multicast but could be implemented above switched fabrics such as
-InfiniBand.
+InfiniBand.
PGM is appropriate for applications that require duplicate-free multicast data
delivery from multiple sources to multiple receivers. PGM does not support
acknowledged delivery, nor does it guarantee ordering of packets from multiple
-senders.
+senders.
PGM is primarly used on internal networks to help integrate disparate systems
through a common communication platform. A lack of IPv4 multicast-enabled
diff --git a/net/openpgm/pkg-plist b/net/openpgm/pkg-plist
index ba85c8b218e7..e30c34515a0e 100644
--- a/net/openpgm/pkg-plist
+++ b/net/openpgm/pkg-plist
@@ -25,30 +25,3 @@ lib/libpgm-5.2.so.0.0.122
lib/libpgm.a
lib/libpgm.so
libdata/pkgconfig/openpgm-5.2.pc
-%%PORTDOCS%%%%DOCSDIR%%/draft-ietf-rmt-bb-pgmcc-03.txt
-%%PORTDOCS%%%%DOCSDIR%%/rfc3208.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/SConscript
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/SConscript89
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/async.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/async.h
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/blocksyncrecv.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/daytime.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/enonblocksyncrecv.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/enonblocksyncrecvmsg.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/enonblocksyncrecvmsgv.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/getopt.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/getopt.h
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/heatmap.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/pgmdump.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/pgmping.cc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/pgmrecv.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/pgmsend.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/pgmtop.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/ping.proto
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/pnonblocksyncrecv.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/purinrecv.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/purinrecvcc.cc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/purinsend.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/purinsendcc.cc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/shortcakerecv.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples/snonblocksyncrecv.c