aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-BBS-UserInfo-Wretch/Makefile
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-11-24 09:47:23 +0800
committerclsung <clsung@FreeBSD.org>2006-11-24 09:47:23 +0800
commitc856a9f683c130f71be83910b1a7bdd59ebd82d2 (patch)
tree78a2a3d2f89808d26386e9fd66a7155de219b3f3 /net/p5-BBS-UserInfo-Wretch/Makefile
parent36f8f1a5ce532fddfbc3e32acb6a706809f963f9 (diff)
downloadfreebsd-ports-gnome-c856a9f683c130f71be83910b1a7bdd59ebd82d2.tar.gz
freebsd-ports-gnome-c856a9f683c130f71be83910b1a7bdd59ebd82d2.tar.zst
freebsd-ports-gnome-c856a9f683c130f71be83910b1a7bdd59ebd82d2.zip
Add p5-BBS-UserInfo-Wretch 0.02, get user information of Wretch-style
BBS. PR: ports/102319 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'net/p5-BBS-UserInfo-Wretch/Makefile')
-rw-r--r--net/p5-BBS-UserInfo-Wretch/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/p5-BBS-UserInfo-Wretch/Makefile b/net/p5-BBS-UserInfo-Wretch/Makefile
new file mode 100644
index 000000000000..fe238378b017
--- /dev/null
+++ b/net/p5-BBS-UserInfo-Wretch/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-BBS-UserInfo-Wretch
+# Date created: 2006-08-20
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= BBS-UserInfo-Wretch
+PORTVERSION= 0.02
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/G/GS/GSLIN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Get user information of Wretch-style BBS
+
+RUN_DEPENDS= ${SITE_PERL}/Expect.pm:${PORTSDIR}/lang/p5-Expect
+
+PERL_CONFIGURE= yes
+
+MAN3= BBS::UserInfo::Wretch.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800 # Inherited from lang/p5-Expect
+IGNORE= requires Perl 5.8.0 or newer. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>