aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-IPv4Addr/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-06-17 10:37:15 +0800
committerwill <will@FreeBSD.org>2000-06-17 10:37:15 +0800
commit6dd7168cddcf03645b7b524d0eaec762ba4a5c26 (patch)
treedde5ee054b255f449dc09b875bfef1cb678c4d3e /net/p5-Net-IPv4Addr/Makefile
parent09860925596143f36628cd7f462f54e90412d7ae (diff)
downloadfreebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.tar.gz
freebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.tar.zst
freebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.zip
Lots and lots of cleanups. Teach p5-* in general about PKGNAMEPREFIX.
Add some missing/wrong dependencies. Show how to respect CC/CFLAGS. Many miscellaneous modifications. I used more excessive hacks to force p5-Jcode and p5-WWW-Search to respect CC/CFLAGS. Patches largely done by: Christian Weisgerber <naddy@mips.inka.de>
Diffstat (limited to 'net/p5-Net-IPv4Addr/Makefile')
-rw-r--r--net/p5-Net-IPv4Addr/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/net/p5-Net-IPv4Addr/Makefile b/net/p5-Net-IPv4Addr/Makefile
index cfacd3bc4f23..51b18c597dc7 100644
--- a/net/p5-Net-IPv4Addr/Makefile
+++ b/net/p5-Net-IPv4Addr/Makefile
@@ -5,12 +5,12 @@
# $FreeBSD$
#
-PORTNAME= p5-Net-IPv4Addr
-PORTVERSION= 0.08
+PORTNAME= Net-IPv4Addr
+PORTVERSION= 0.09
CATEGORIES= net perl5
-# not using CPAN due to them messing up the filename and version numbers
-MASTER_SITES= http://indev.insu.com/sources/
-DISTNAME= Net-IPv4Addr-${PORTVERSION}
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
MAINTAINER= bradh@uunet.co.za
@@ -21,6 +21,7 @@ MAN3= Net::IPv4Addr.3
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL PREFIX=${PREFIX}
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ PREFIX=${PREFIX}
.include <bsd.port.mk>