aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-SFTP
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2003-10-13 23:21:57 +0800
committermat <mat@FreeBSD.org>2003-10-13 23:21:57 +0800
commit16e79df64d5eb99b3c41664b5fea2e2c2a524ece (patch)
treece631a51822dd038780788b4d6e044871c6717fd /net/p5-Net-SFTP
parent35854b2ea73ba1351cb219b007f7cab6ecb54239 (diff)
downloadfreebsd-ports-gnome-16e79df64d5eb99b3c41664b5fea2e2c2a524ece.tar.gz
freebsd-ports-gnome-16e79df64d5eb99b3c41664b5fea2e2c2a524ece.tar.zst
freebsd-ports-gnome-16e79df64d5eb99b3c41664b5fea2e2c2a524ece.zip
Add p5-Net-SFTP 0.05,
Perl5 module implementing Secure File Transfer Protocol client. PR: 57923 Submitted by: Trevor Corpropst <tcornpropst@cox.net>
Diffstat (limited to 'net/p5-Net-SFTP')
-rw-r--r--net/p5-Net-SFTP/Makefile29
-rw-r--r--net/p5-Net-SFTP/distinfo1
-rw-r--r--net/p5-Net-SFTP/pkg-descr4
-rw-r--r--net/p5-Net-SFTP/pkg-plist10
4 files changed, 44 insertions, 0 deletions
diff --git a/net/p5-Net-SFTP/Makefile b/net/p5-Net-SFTP/Makefile
new file mode 100644
index 000000000000..cf0de3b95912
--- /dev/null
+++ b/net/p5-Net-SFTP/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Net-SFTP
+# Date created: 08 Oct 2003
+# Whom: Trevor Corpropst <tcornpropst@cox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SFTP
+PORTVERSION= 0.05
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tcornpropst@cox.net
+COMMENT= Perl5 module implementing Secure File Transfer Protocol client
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/SSH/Perl.pm:${PORTSDIR}/net/p5-Net-SSH-Perl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::SFTP.3 \
+ Net::SFTP::Attributes.3 \
+ Net::SFTP::Buffer.3 \
+ Net::SFTP::Constants.3 \
+ Net::SFTP::Util.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-SFTP/distinfo b/net/p5-Net-SFTP/distinfo
new file mode 100644
index 000000000000..6c74e661a691
--- /dev/null
+++ b/net/p5-Net-SFTP/distinfo
@@ -0,0 +1 @@
+MD5 (Net-SFTP-0.05.tar.gz) = a062c29781fff4ea2f0d4629326ceed3
diff --git a/net/p5-Net-SFTP/pkg-descr b/net/p5-Net-SFTP/pkg-descr
new file mode 100644
index 000000000000..2e41051b153f
--- /dev/null
+++ b/net/p5-Net-SFTP/pkg-descr
@@ -0,0 +1,4 @@
+Perl5 Module implementing Secure File Transfer Protocol client
+
+- Trevor Cornpropst
+tcornpropst@cox.net
diff --git a/net/p5-Net-SFTP/pkg-plist b/net/p5-Net-SFTP/pkg-plist
new file mode 100644
index 000000000000..30c4e0466b04
--- /dev/null
+++ b/net/p5-Net-SFTP/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/Net/SFTP.pm
+%%SITE_PERL%%/Net/SFTP/Attributes.pm
+%%SITE_PERL%%/Net/SFTP/Buffer.pm
+%%SITE_PERL%%/Net/SFTP/Constants.pm
+%%SITE_PERL%%/Net/SFTP/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SFTP/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SFTP
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Net/SFTP
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true