aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-POE-Component-Client-Traceroute
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-08-10 10:04:43 +0800
committerclsung <clsung@FreeBSD.org>2006-08-10 10:04:43 +0800
commit1045ff2311db1c6aef19c8ea880428e8d2e443dd (patch)
treecd085096218eee5e62b137f8c25e12e3752c76ff /net/p5-POE-Component-Client-Traceroute
parent2c58d83a5d1e15f34450a55970352de3263b83be (diff)
downloadfreebsd-ports-gnome-1045ff2311db1c6aef19c8ea880428e8d2e443dd.tar.gz
freebsd-ports-gnome-1045ff2311db1c6aef19c8ea880428e8d2e443dd.tar.zst
freebsd-ports-gnome-1045ff2311db1c6aef19c8ea880428e8d2e443dd.zip
Add p5-POE-Component-Client-Traceroute 0.11, a non-blocking traceroute
client. PR: ports/101735 Submitted by: Jin-Shan Tseng <tjs at cdpa.nsysu.edu.tw>
Diffstat (limited to 'net/p5-POE-Component-Client-Traceroute')
-rw-r--r--net/p5-POE-Component-Client-Traceroute/Makefile32
-rw-r--r--net/p5-POE-Component-Client-Traceroute/distinfo3
-rw-r--r--net/p5-POE-Component-Client-Traceroute/pkg-descr6
-rw-r--r--net/p5-POE-Component-Client-Traceroute/pkg-plist10
4 files changed, 51 insertions, 0 deletions
diff --git a/net/p5-POE-Component-Client-Traceroute/Makefile b/net/p5-POE-Component-Client-Traceroute/Makefile
new file mode 100644
index 000000000000..5c2276854e3a
--- /dev/null
+++ b/net/p5-POE-Component-Client-Traceroute/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-POE-Component-Client-Traceroute
+# Date created: 2006-08-09
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Client-Traceroute
+PORTVERSION= 0.11
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= A non-blocking traceroute client
+
+RUN_DEPENDS= p5-POE>=0.11:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/${PERL_ARCH}/Net/RawIP.pm:${PORTSDIR}/net/p5-Net-RawIP
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Client::Traceroute.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500702
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-POE-Component-Client-Traceroute/distinfo b/net/p5-POE-Component-Client-Traceroute/distinfo
new file mode 100644
index 000000000000..54e442ccb77d
--- /dev/null
+++ b/net/p5-POE-Component-Client-Traceroute/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Component-Client-Traceroute-0.11.tar.gz) = 3828d37d7997f28374d3fc188ef05e7c
+SHA256 (POE-Component-Client-Traceroute-0.11.tar.gz) = ea99f668379a1839183a40c3a149b51dd0e8471bdf3c506ad9c6c3b21f1b8ebf
+SIZE (POE-Component-Client-Traceroute-0.11.tar.gz) = 12431
diff --git a/net/p5-POE-Component-Client-Traceroute/pkg-descr b/net/p5-POE-Component-Client-Traceroute/pkg-descr
new file mode 100644
index 000000000000..e3ce87e0116a
--- /dev/null
+++ b/net/p5-POE-Component-Client-Traceroute/pkg-descr
@@ -0,0 +1,6 @@
+POE::Component::Client::Traceroute is a non-blocking Traceroute
+client. It lets several other sessions traceroute through it in
+parallel, and it lets them continue doing other things while
+they wait for responses.
+
+WWW: http://search.cpan.org/dist/POE-Component-Client-Traceroute/
diff --git a/net/p5-POE-Component-Client-Traceroute/pkg-plist b/net/p5-POE-Component-Client-Traceroute/pkg-plist
new file mode 100644
index 000000000000..19c35ed91c59
--- /dev/null
+++ b/net/p5-POE-Component-Client-Traceroute/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/Traceroute/.packlist
+%%SITE_PERL%%/POE/Component/Client/Traceroute.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/Traceroute
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/POE/Component/Client
+@dirrmtry %%SITE_PERL%%/POE/Component
+@dirrmtry %%SITE_PERL%%/POE