aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-PlRPC
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2003-02-21 00:33:26 +0800
committersobomax <sobomax@FreeBSD.org>2003-02-21 00:33:26 +0800
commit1e607f868b5505e10fabe70f19c1c6e491e4d1a0 (patch)
tree5a6539846b1be0d7960d421883f382b1984b610b /net/p5-PlRPC
parent548c9ae86f72ebe1570fffefb0f5b4dd3f3c0ab1 (diff)
downloadfreebsd-ports-gnome-1e607f868b5505e10fabe70f19c1c6e491e4d1a0.tar.gz
freebsd-ports-gnome-1e607f868b5505e10fabe70f19c1c6e491e4d1a0.tar.zst
freebsd-ports-gnome-1e607f868b5505e10fabe70f19c1c6e491e4d1a0.zip
Conditionalise several dependencies on PERL_LEVEL to make those ports more
friendly for perl-5.8.0, which has those dependencies included into the base distribution. Sponsired by: Porta Software Ltd
Diffstat (limited to 'net/p5-PlRPC')
-rw-r--r--net/p5-PlRPC/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/net/p5-PlRPC/Makefile b/net/p5-PlRPC/Makefile
index 37577bce4541..430ea4dbc1de 100644
--- a/net/p5-PlRPC/Makefile
+++ b/net/p5-PlRPC/Makefile
@@ -14,8 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= vanilla@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/Daemon.pm:${PORTSDIR}/net/p5-Net-Daemon \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/Daemon.pm:${PORTSDIR}/net/p5-Net-Daemon
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -25,4 +24,10 @@ MAN3= Bundle::PlRPC.3 \
RPC::PlServer.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+.endif
+
+.include <bsd.port.post.mk>