aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-REST-Google
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-03-14 01:29:58 +0800
committeradamw <adamw@FreeBSD.org>2015-03-14 01:29:58 +0800
commit3285716aaeafc0b799b7d0f09455fb838f7423eb (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /net/p5-REST-Google
parent0e44743df6c6b7c3f4bc9ebe5b47c9868ff2ca6d (diff)
downloadfreebsd-ports-gnome-3285716aaeafc0b799b7d0f09455fb838f7423eb.tar.gz
freebsd-ports-gnome-3285716aaeafc0b799b7d0f09455fb838f7423eb.tar.zst
freebsd-ports-gnome-3285716aaeafc0b799b7d0f09455fb838f7423eb.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Diffstat (limited to 'net/p5-REST-Google')
-rw-r--r--net/p5-REST-Google/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/net/p5-REST-Google/Makefile b/net/p5-REST-Google/Makefile
index 98cfd596b3f4..6172afb53135 100644
--- a/net/p5-REST-Google/Makefile
+++ b/net/p5-REST-Google/Makefile
@@ -3,7 +3,7 @@
PORTNAME= REST-Google
PORTVERSION= 1.0.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:EJS
@@ -13,7 +13,6 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Access Google REST (aka AJAX) API from Perl
RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
- p5-version>=0.50:${PORTSDIR}/devel/p5-version \
p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Class-Data-Inheritable>0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
p5-URI>=1.35:${PORTSDIR}/net/p5-URI \