aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-SNMP
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-06-17 10:37:15 +0800
committerwill <will@FreeBSD.org>2000-06-17 10:37:15 +0800
commit6dd7168cddcf03645b7b524d0eaec762ba4a5c26 (patch)
treedde5ee054b255f449dc09b875bfef1cb678c4d3e /net/p5-SNMP
parent09860925596143f36628cd7f462f54e90412d7ae (diff)
downloadfreebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.tar.gz
freebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.tar.zst
freebsd-ports-gnome-6dd7168cddcf03645b7b524d0eaec762ba4a5c26.zip
Lots and lots of cleanups. Teach p5-* in general about PKGNAMEPREFIX.
Add some missing/wrong dependencies. Show how to respect CC/CFLAGS. Many miscellaneous modifications. I used more excessive hacks to force p5-Jcode and p5-WWW-Search to respect CC/CFLAGS. Patches largely done by: Christian Weisgerber <naddy@mips.inka.de>
Diffstat (limited to 'net/p5-SNMP')
-rw-r--r--net/p5-SNMP/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/net/p5-SNMP/Makefile b/net/p5-SNMP/Makefile
index 46c99fd7b433..5b8f730ae20b 100644
--- a/net/p5-SNMP/Makefile
+++ b/net/p5-SNMP/Makefile
@@ -5,23 +5,25 @@
# $FreeBSD$
#
-PORTNAME= p5-SNMP
+PORTNAME= SNMP
PORTVERSION= 1.8.1
CATEGORIES= net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= SNMP
-DISTNAME= SNMP-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= jfitz@FreeBSD.org
LIB_DEPENDS= snmp.4:${PORTSDIR}/net/ucd-snmp
-USE_PERL5= YES
+USE_PERL5= yes
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
post-install:
- @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/lib/perl5/site_perl/README.SNMP
+ @${INSTALL_DATA} ${WRKSRC}/README \
+ ${PREFIX}/lib/perl5/site_perl/README.SNMP
.include <bsd.port.mk>