aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-SOAP/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-01-04 07:43:25 +0800
committerwill <will@FreeBSD.org>2001-01-04 07:43:25 +0800
commitb2c67add43e7f574b0bef4fb4a34a1440a34a902 (patch)
tree7d26ad46bb7b0899cefa9f742e1b8e9927e5eaa0 /net/p5-SOAP/Makefile
parent0e50a74c2e7d0352e48cef3dacaa379c72fcec37 (diff)
downloadfreebsd-ports-gnome-b2c67add43e7f574b0bef4fb4a34a1440a34a902.tar.gz
freebsd-ports-gnome-b2c67add43e7f574b0bef4fb4a34a1440a34a902.tar.zst
freebsd-ports-gnome-b2c67add43e7f574b0bef4fb4a34a1440a34a902.zip
Add p5-SOAP 0.28, perl modules providing an API to the Simple Object Access
Protocol.
Diffstat (limited to 'net/p5-SOAP/Makefile')
-rw-r--r--net/p5-SOAP/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/net/p5-SOAP/Makefile b/net/p5-SOAP/Makefile
new file mode 100644
index 000000000000..973bbc9f39c4
--- /dev/null
+++ b/net/p5-SOAP/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: SOAP
+# Date created: Wed Jan 3 10:01:46 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= SOAP
+PORTVERSION= 0.28
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= SOAP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww perl5
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= SOAP.3 SOAP::SimpleTypeWrapper.3 SOAP::Parser.3 \
+ SOAP::EnvelopeMaker.3 SOAP::GenericScalarSerializer.3 \
+ SOAP::Transport::HTTP::Apache.3 SOAP::TypedPrimitiveSerializer.3 \
+ SOAP::GenericInputStream.3 SOAP::Serializer.3 \
+ SOAP::GenericHashSerializer.3 SOAP::OutputStream.3 \
+ SOAP::Transport::HTTP::CGI.3 SOAP::Packager.3 SOAP::Envelope.3 \
+ SOAP::TypedPrimitive.3 SOAP::StructSerializer.3 \
+ SOAP::Transport::HTTP::Server.3 SOAP::Defs.3 SOAP::Struct.3 \
+ SOAP::TypeMapper.3 SOAP::Transport::HTTP::Client.3
+
+.include <bsd.port.mk>