aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Socket-Class
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-04-23 17:14:40 +0800
committermiwi <miwi@FreeBSD.org>2009-04-23 17:14:40 +0800
commit6a9ed23b25a24e12651c8c3ff193d1526f4d36f6 (patch)
tree1e192c2b351a9633249afa649e2b36ed69fb1af1 /net/p5-Socket-Class
parent0754900cd8a492053a66c9d3905b72464039a8c6 (diff)
downloadfreebsd-ports-gnome-6a9ed23b25a24e12651c8c3ff193d1526f4d36f6.tar.gz
freebsd-ports-gnome-6a9ed23b25a24e12651c8c3ff193d1526f4d36f6.tar.zst
freebsd-ports-gnome-6a9ed23b25a24e12651c8c3ff193d1526f4d36f6.zip
Socket::Class provides a simple, fast and efficient way to
communicate with sockets. It operates outside of the Perl IO layer and can be used as a replacement to IO::Socket. Little parts of Bluetooth technology has been integrated. WWW: http://search.cpan.org/dist/Socket-Class/ PR: ports/133796 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'net/p5-Socket-Class')
-rw-r--r--net/p5-Socket-Class/Makefile23
-rw-r--r--net/p5-Socket-Class/distinfo3
-rw-r--r--net/p5-Socket-Class/pkg-descr6
-rw-r--r--net/p5-Socket-Class/pkg-plist17
4 files changed, 49 insertions, 0 deletions
diff --git a/net/p5-Socket-Class/Makefile b/net/p5-Socket-Class/Makefile
new file mode 100644
index 000000000000..242ef32e7d67
--- /dev/null
+++ b/net/p5-Socket-Class/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-Socket-Class
+# Date created: 17 April, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Socket-Class
+PORTVERSION= 2.11
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A perl class to communicate with sockets
+
+PERL_CONFIGURE= yes
+
+MAN3= Socket::Class::Const.3 \
+ Socket::Class::SSL.3 \
+ Socket::Class.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Socket-Class/distinfo b/net/p5-Socket-Class/distinfo
new file mode 100644
index 000000000000..a0c5c70e6ad5
--- /dev/null
+++ b/net/p5-Socket-Class/distinfo
@@ -0,0 +1,3 @@
+MD5 (Socket-Class-2.11.tar.gz) = 8384ddf2ede96c4515dfe6259902dfcb
+SHA256 (Socket-Class-2.11.tar.gz) = 270704b232201d8880282e9e491c84f3e805af8d242cfdd21396835bae75dff1
+SIZE (Socket-Class-2.11.tar.gz) = 4222682
diff --git a/net/p5-Socket-Class/pkg-descr b/net/p5-Socket-Class/pkg-descr
new file mode 100644
index 000000000000..ac31adcfeed3
--- /dev/null
+++ b/net/p5-Socket-Class/pkg-descr
@@ -0,0 +1,6 @@
+Socket::Class provides a simple, fast and efficient way to
+communicate with sockets. It operates outside of the Perl
+IO layer and can be used as a replacement to IO::Socket.
+Little parts of Bluetooth technology has been integrated.
+
+WWW: http://search.cpan.org/dist/Socket-Class/
diff --git a/net/p5-Socket-Class/pkg-plist b/net/p5-Socket-Class/pkg-plist
new file mode 100644
index 000000000000..00658ee30734
--- /dev/null
+++ b/net/p5-Socket-Class/pkg-plist
@@ -0,0 +1,17 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Socket/Class/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Socket/Class/Class.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Socket/Class/Class.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Socket/Class/mod_sc.h
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Socket/Class/Const/Const.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Socket/Class/Const/Const.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Socket/Class/SSL/SSL.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Socket/Class/SSL/SSL.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/Socket/Class.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Socket/Class/Const.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Socket/Class/SSL.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Socket/Class/SSL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Socket/Class/Const
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Socket/Class
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Socket
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Socket/Class
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Socket