aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-URI
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2003-02-21 00:33:26 +0800
committersobomax <sobomax@FreeBSD.org>2003-02-21 00:33:26 +0800
commit1e607f868b5505e10fabe70f19c1c6e491e4d1a0 (patch)
tree5a6539846b1be0d7960d421883f382b1984b610b /net/p5-URI
parent548c9ae86f72ebe1570fffefb0f5b4dd3f3c0ab1 (diff)
downloadfreebsd-ports-gnome-1e607f868b5505e10fabe70f19c1c6e491e4d1a0.tar.gz
freebsd-ports-gnome-1e607f868b5505e10fabe70f19c1c6e491e4d1a0.tar.zst
freebsd-ports-gnome-1e607f868b5505e10fabe70f19c1c6e491e4d1a0.zip
Conditionalise several dependencies on PERL_LEVEL to make those ports more
friendly for perl-5.8.0, which has those dependencies included into the base distribution. Sponsired by: Porta Software Ltd
Diffstat (limited to 'net/p5-URI')
-rw-r--r--net/p5-URI/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/net/p5-URI/Makefile b/net/p5-URI/Makefile
index b1a5d659b92f..f72111820736 100644
--- a/net/p5-URI/Makefile
+++ b/net/p5-URI/Makefile
@@ -14,8 +14,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= erwin@lansing.dk
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
-
PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
@@ -29,8 +27,15 @@ MAN3= URI.3 \
URI::file.3 \
URI::ldap.3
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
post-patch:
${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1);/' \
${WRKSRC}/URI/urn.pm
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>