aboutsummaryrefslogtreecommitdiffstats
path: root/net/pear-SOAP
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-12-17 10:15:13 +0800
committerbapt <bapt@FreeBSD.org>2012-12-17 10:15:13 +0800
commit421fdbd458a94c9af983273f7ee42d99120d59d9 (patch)
tree2462f02d26b3d6c876b0b158f0a6aa557f06a219 /net/pear-SOAP
parentb254d40ce314ab3439c8eab6f789fb254328f461 (diff)
downloadfreebsd-ports-gnome-421fdbd458a94c9af983273f7ee42d99120d59d9.tar.gz
freebsd-ports-gnome-421fdbd458a94c9af983273f7ee42d99120d59d9.tar.zst
freebsd-ports-gnome-421fdbd458a94c9af983273f7ee42d99120d59d9.zip
Convert miwi's ports to new Options framework
While here fix some consistency in PEAR options name bumped revision of net/icpld and net/ipsumdump because IPV6 is now on Approved by: miwi (maintainer)
Diffstat (limited to 'net/pear-SOAP')
-rw-r--r--net/pear-SOAP/Makefile23
1 files changed, 10 insertions, 13 deletions
diff --git a/net/pear-SOAP/Makefile b/net/pear-SOAP/Makefile
index c36ca11e681e..fa99987fb872 100644
--- a/net/pear-SOAP/Makefile
+++ b/net/pear-SOAP/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-SOAP
-# Date created: 05 April 2004
-# Whom: Thierry Thomas (<thierry@FreeBSD.org>)
-#
+# Created by: Thierry Thomas (<thierry@FreeBSD.org>)
# $FreeBSD$
-#
PORTNAME= SOAP
PORTVERSION= 0.13.0
@@ -18,25 +14,26 @@ RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
LATEST_LINK= pear-SOAP
-OPTIONS= PEAR_MAIL "PEAR::Mail support" off \
- PEAR_MAIL_MIME "PEAR::Mail::Mime support" off \
- PEAR_NET_DIME "PEAR::Net::DIME support" off
+OPTIONS_DEFINE= PEAR_MAIL PEAR_MAIL_MIME PEAR_NET_DIME
+PEAR_MAIL_DESC= PEAR::Mail support
+PEAR_MAIL_MIME_DESC= PEAR::Mail::Mime support
+PEAR_NET_DIME_DESC= PEAR::Net::DIME support
PEAR_AUTOINSTALL=yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PEAR_MAIL)
+.if ${PORT_OPTIONS:MPEAR_MAIL}
BUILD_DEPENDS+= ${PEARDIR}/Mail.php:${PORTSDIR}/mail/pear-Mail
.endif
-.if defined(WITH_PEAR_MAIL_MIME)
+.if ${PORT_OPTIONS:MPEAR_MAIL_MIME}
BUILD_DEPENDS+= ${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime
.endif
-.if defined(WITH_PEAR_NET_DIME)
+.if ${PORT_OPTIONS:MPEAR_NET_DIME}
BUILD_DEPENDS+= ${PEARDIR}/Net/DIME.php:${PORTSDIR}/net/pear-Net_DIME
.endif
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>