aboutsummaryrefslogtreecommitdiffstats
path: root/net/pecl-mosquitto/Makefile
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2019-07-22 03:57:01 +0800
committerpi <pi@FreeBSD.org>2019-07-22 03:57:01 +0800
commitbc5b12a7515a425c5b900eb2e600e02433718bf0 (patch)
treec9b83ecd1c86471b673202ce322f677054842dfc /net/pecl-mosquitto/Makefile
parent2bae9d09095dca786090d1cf2f53204f69a8ef20 (diff)
downloadfreebsd-ports-gnome-bc5b12a7515a425c5b900eb2e600e02433718bf0.tar.gz
freebsd-ports-gnome-bc5b12a7515a425c5b900eb2e600e02433718bf0.tar.zst
freebsd-ports-gnome-bc5b12a7515a425c5b900eb2e600e02433718bf0.zip
New/resurrected port: net/pecl-mosquitto
Mosquitto provides support for the MQTT protocol, including publishing, subscribing, and an event loop. WWW: https://pecl.php.net/package/Mosquitto Version 0.4.0 runs with PHP 7.x PR: 239317 Submitted by: Daniel Morante <daniel@morante.net>
Diffstat (limited to 'net/pecl-mosquitto/Makefile')
-rw-r--r--net/pecl-mosquitto/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/net/pecl-mosquitto/Makefile b/net/pecl-mosquitto/Makefile
new file mode 100644
index 000000000000..4f18bd71d28c
--- /dev/null
+++ b/net/pecl-mosquitto/Makefile
@@ -0,0 +1,18 @@
+# Created by: Gasol Wu <gasol.wu@gmail.com>
+# $FreeBSD$
+
+PORTNAME= mosquitto
+PORTVERSION= 0.4.0
+CATEGORIES= net pear
+DISTNAME= Mosquitto-${PORTVERSION}
+
+MAINTAINER= gasol.wu@gmail.com
+COMMENT= Extension for libmosquitto
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= mosquitto>=0:net/mosquitto
+
+USES= php:pecl
+
+.include <bsd.port.mk>