aboutsummaryrefslogtreecommitdiffstats
path: root/net/pecl-radius
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2012-05-23 15:41:41 +0800
committerale <ale@FreeBSD.org>2012-05-23 15:41:41 +0800
commit770126aec6e20f38879247278664fb82c2e88a8f (patch)
tree418db05369d64ba653b861f66117a916f1fde9fb /net/pecl-radius
parenta849771e5270c428b68928887142572358f11c54 (diff)
downloadfreebsd-ports-gnome-770126aec6e20f38879247278664fb82c2e88a8f.tar.gz
freebsd-ports-gnome-770126aec6e20f38879247278664fb82c2e88a8f.tar.zst
freebsd-ports-gnome-770126aec6e20f38879247278664fb82c2e88a8f.zip
Fix for php 5.4.
Diffstat (limited to 'net/pecl-radius')
-rw-r--r--net/pecl-radius/Makefile2
-rw-r--r--net/pecl-radius/files/patch-radius.c11
2 files changed, 11 insertions, 2 deletions
diff --git a/net/pecl-radius/Makefile b/net/pecl-radius/Makefile
index 95b0bcfd84e4..40d8974b0b64 100644
--- a/net/pecl-radius/Makefile
+++ b/net/pecl-radius/Makefile
@@ -18,8 +18,6 @@ COMMENT= Radius client library for PHP
USE_PHP= yes
USE_PHPEXT= yes
-DEFAULT_PHP_VER=53
-IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-radius
diff --git a/net/pecl-radius/files/patch-radius.c b/net/pecl-radius/files/patch-radius.c
new file mode 100644
index 000000000000..f7208cfd4141
--- /dev/null
+++ b/net/pecl-radius/files/patch-radius.c
@@ -0,0 +1,11 @@
+--- radius.c.orig 2012-05-23 09:36:48.000000000 +0200
++++ radius.c 2012-05-23 09:37:04.000000000 +0200
+@@ -62,7 +62,7 @@
+ *
+ * Every user visible function must have an entry in radius_functions[].
+ */
+-function_entry radius_functions[] = {
++zend_function_entry radius_functions[] = {
+ PHP_FE(radius_auth_open, NULL)
+ PHP_FE(radius_acct_open, NULL)
+ PHP_FE(radius_close, NULL)