aboutsummaryrefslogtreecommitdiffstats
path: root/net/phpldapadmin/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-05-15 16:19:04 +0800
committerthierry <thierry@FreeBSD.org>2004-05-15 16:19:04 +0800
commit6b4c9542293b280493c04b7311e68deaacab9da3 (patch)
treec19438eac9851da06ba5dc12bd4931f472d63ead /net/phpldapadmin/Makefile
parente67907c9fb0ca0f35515bbd61e56ea963690af3a (diff)
downloadfreebsd-ports-gnome-6b4c9542293b280493c04b7311e68deaacab9da3.tar.gz
freebsd-ports-gnome-6b4c9542293b280493c04b7311e68deaacab9da3.tar.zst
freebsd-ports-gnome-6b4c9542293b280493c04b7311e68deaacab9da3.zip
Add phpldapadmin 0.9.4b, a set of PHP-scripts to administer LDAP
servers over the web. PR: 66154 Submitted by: Matthew Seaman
Diffstat (limited to 'net/phpldapadmin/Makefile')
-rw-r--r--net/phpldapadmin/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/net/phpldapadmin/Makefile b/net/phpldapadmin/Makefile
new file mode 100644
index 000000000000..e6d92f49e342
--- /dev/null
+++ b/net/phpldapadmin/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: phpLDAPadmin
+# Date created: 30 Apr 2004
+# Whom: Matthew Seaman
+#
+# $FreeBSD$
+#
+
+PORTNAME= phpldapadmin
+PORTVERSION= 0.9.4b
+CATEGORIES= net www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= phpldapadmin
+
+MAINTAINER= m.seaman@infracaninophile.co.uk
+COMMENT= A set of PHP-scripts to administer LDAP servers over the web
+
+USE_PHP= yes
+WANT_PHP_WEB= yes
+NO_BUILD= yes
+
+WWWDIR?= www/${PORTNAME}
+
+MSG_SKEL= ${PKGDIR}/pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+PLIST= ${WRKDIR}/plist
+PLIST_SUB+= WWWDIR=${WWWDIR}
+
+.SILENT:
+
+post-patch:
+ ${RM} -f ${PLIST}
+ cd ${WRKSRC} ; \
+ ${FIND} . ! -type d ! -name .cvsignore | ${SORT} | \
+ ${SED} "s,^.,%%WWWDIR%%," >${PLIST} ; \
+ ${FIND} . -type d | ${SORT} -r | \
+ ${SED} "s,^.,@dirrm %%WWWDIR%%," >>${PLIST}
+ ${SED} -e 's,%%WWWDIR%%,${WWWDIR},g' \
+ -e 's,%%PREFIX%%,${PREFIX},g' ${MSG_SKEL} > ${PKGMESSAGE}
+
+do-install:
+ cd ${WRKSRC} ; \
+ for src in $$( ${FIND} . ! -name .cvsignore ) ; do \
+ dst=${PREFIX}/${WWWDIR}$${src#.} ; \
+ if ${TEST} -d $$src ; then \
+ ${MKDIR} $$dst ; \
+ else \
+ ${INSTALL_DATA} $$src $$dst ; \
+ fi \
+ done
+
+post-install:
+ ${ECHO_MSG}
+ ${CAT} ${PKGMESSAGE}
+ ${ECHO_MSG}
+
+.include <bsd.port.mk>