aboutsummaryrefslogtreecommitdiffstats
path: root/net/pload
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2009-06-21 07:16:30 +0800
committerdhn <dhn@FreeBSD.org>2009-06-21 07:16:30 +0800
commit6651c3bf1cea99303d137d415da2ba60a60adcbf (patch)
tree405dcd3bf964456914c5c09aa4646c88b8300685 /net/pload
parentded3e401f9584d60b39c07c308fada73f6338e4b (diff)
downloadfreebsd-ports-gnome-6651c3bf1cea99303d137d415da2ba60a60adcbf.tar.gz
freebsd-ports-gnome-6651c3bf1cea99303d137d415da2ba60a60adcbf.tar.zst
freebsd-ports-gnome-6651c3bf1cea99303d137d415da2ba60a60adcbf.zip
- Fix build on 8.x
- Bump PORTREVISION PR: ports/135864 Submitted by: J.R. Oldroyd <fbsd@opal.com> (maintainer)
Diffstat (limited to 'net/pload')
-rw-r--r--net/pload/Makefile12
-rw-r--r--net/pload/files/patch-ioctl_stats.c38
2 files changed, 35 insertions, 15 deletions
diff --git a/net/pload/Makefile b/net/pload/Makefile
index 47b41008de0a..1c0400768047 100644
--- a/net/pload/Makefile
+++ b/net/pload/Makefile
@@ -7,10 +7,10 @@
PORTNAME= pload
PORTVERSION= 0.9.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net sysutils
MASTER_SITES= ${MASTER_SITE_LOCAL} \
- http://opal.com/freebsd/ports/net/pload/
+ http://opal.com/jr/freebsd/ports/net/pload/
MASTER_SITE_SUBDIR= pav
MAINTAINER= fbsd@opal.com
@@ -24,10 +24,4 @@ MAN1= pload.1
MANCOMPRESSED= yes
PLIST_FILES= bin/pload
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 800064
-BROKEN= does not build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/pload/files/patch-ioctl_stats.c b/net/pload/files/patch-ioctl_stats.c
index ba61ce4d94bc..83962721b2c9 100644
--- a/net/pload/files/patch-ioctl_stats.c
+++ b/net/pload/files/patch-ioctl_stats.c
@@ -1,5 +1,5 @@
---- ioctl_stat.c.orig Tue Feb 1 08:11:24 2000
-+++ ioctl_stat.c Mon Oct 18 22:32:49 2004
+--- ioctl_stat.c.orig 2000-02-01 02:11:24.000000000 -0500
++++ ioctl_stat.c 2009-06-15 15:30:03.000000000 -0400
@@ -30,6 +30,12 @@
#include <fcntl.h> /* open */
#include <sys/ioctl.h> /* ioctl */
@@ -13,10 +13,23 @@
#ifndef STREAMS /* Linux, FreeBSD, NetBSD, Ultrix */
# include <sys/socket.h> /* socket */
-@@ -63,6 +69,16 @@
+@@ -39,8 +45,10 @@
+ # include <linux/if_ppp.h>
+ # else /* most everything else */
+ # include <net/if.h>
+-# include <net/ppp_defs.h>
+-# include <net/if_ppp.h>
++# if !defined(__FreeBSD__)
++# include <net/ppp_defs.h>
++# include <net/if_ppp.h>
++# endif /* ! __FreeBSD__ */
+ # endif /* linux && __GLIBC__ < 2 */
+ #else /* STREAMS */ /* Solaris, SunOS, OSF/1, SVR4 */
+ # include <net/ppp_defs.h>
+@@ -61,8 +69,18 @@
+ void ioctl_stat(if_data *ifd)
+ {
struct ifreq ifr;
- struct ifpppstatsreq req;
-
+#ifdef __FreeBSD__
+ static int if_ix = -1;
+ struct ifmibdata ifmd;
@@ -25,12 +38,25 @@
+ size_t nr_ifs_sz = sizeof(nr_ifs);
+ int name[6];
+ int i;
++#else
+ struct ifpppstatsreq req;
+-
+#endif
+
if (!ifd->s) getsocket(ifd);
memset(&ifr, 0, sizeof(ifr));
-@@ -84,18 +100,36 @@
+@@ -76,7 +94,9 @@
+ return;
+ }
+
++#ifndef __FreeBSD__
+ memset(&req, 0, sizeof(req));
++#endif
+
+ #ifdef linux
+ req.stats_ptr = (caddr_t) &req.stats;
+@@ -84,18 +104,36 @@
#define ifr_name ifr__name
#endif