aboutsummaryrefslogtreecommitdiffstats
path: root/net/pppoa
diff options
context:
space:
mode:
authorbrian <brian@FreeBSD.org>2001-08-31 06:07:36 +0800
committerbrian <brian@FreeBSD.org>2001-08-31 06:07:36 +0800
commit5a97936dc9eb447d6a5bab1c7de13cea232d8c0b (patch)
tree89d7bea3a6c56888f784f3416f9d55da3de80054 /net/pppoa
parent2dcdf0a5b95211b029cee62ea03a7d0ce2ef8913 (diff)
downloadfreebsd-ports-gnome-5a97936dc9eb447d6a5bab1c7de13cea232d8c0b.tar.gz
freebsd-ports-gnome-5a97936dc9eb447d6a5bab1c7de13cea232d8c0b.tar.zst
freebsd-ports-gnome-5a97936dc9eb447d6a5bab1c7de13cea232d8c0b.zip
PPPoA talks to an Alcatel Speedtouch USB ADSL modem device using ppp(8),
implementing PPP over USB.
Diffstat (limited to 'net/pppoa')
-rw-r--r--net/pppoa/Makefile33
-rw-r--r--net/pppoa/distinfo2
-rw-r--r--net/pppoa/pkg-comment1
-rw-r--r--net/pppoa/pkg-descr14
-rw-r--r--net/pppoa/pkg-plist7
5 files changed, 57 insertions, 0 deletions
diff --git a/net/pppoa/Makefile b/net/pppoa/Makefile
new file mode 100644
index 000000000000..39919482f1f0
--- /dev/null
+++ b/net/pppoa/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: speedtouch
+# Date created: August 30 2001
+# Whom: Brian Somers <brian@freebsd-services.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pppoa
+PORTVERSION= 20010815
+CATEGORIES= net
+MASTER_SITES= http://www.xsproject.org/speedtouch/files/ \
+ http://benoit.papillault.free.fr/speedtouch/ \
+ http://www.alcatel.com/consumer/dsl/
+DISTFILES= ${SPEEDTOUCH}.tar.gz speedmgmt.tar.gz
+
+MAINTAINER= brian@Awfulhak.org
+
+HAS_CONFIGURE= yes
+SPEEDTOUCH= speedtouch-15082001
+NO_CDROM= "http://www.alcatel.com/consumer/dsl/disclaimer_lx.htm"
+RESTRICTED_FILES= speedmgmt.tar.gz
+
+WRKSRC= ${WRKDIR}/${SPEEDTOUCH}
+
+post-install:
+ if [ ! -d ${PREFIX}/libdata ]; then \
+ ${MKDIR} ${PREFIX}/libdata; \
+ ${CHMOD} 775 ${PREFIX}/libdata; \
+ ${CHOWN} root:wheel ${PREFIX}/arpwatch; \
+ fi
+ ${INSTALL_DATA} ${WRKSRC}/../mgmt/mgmt.o ${PREFIX}/libdata/.
+
+.include <bsd.port.mk>
diff --git a/net/pppoa/distinfo b/net/pppoa/distinfo
new file mode 100644
index 000000000000..9c89a79a4afc
--- /dev/null
+++ b/net/pppoa/distinfo
@@ -0,0 +1,2 @@
+MD5 (speedtouch-15082001.tar.gz) = cdcde701d89faf636a6743ee25d580e6
+MD5 (speedmgmt.tar.gz) = 102dc7a457c3942ee21dc834db68eac2
diff --git a/net/pppoa/pkg-comment b/net/pppoa/pkg-comment
new file mode 100644
index 000000000000..ee5fbb570cd8
--- /dev/null
+++ b/net/pppoa/pkg-comment
@@ -0,0 +1 @@
+Run PPP over Alcatel's USB Speedtouch device
diff --git a/net/pppoa/pkg-descr b/net/pppoa/pkg-descr
new file mode 100644
index 000000000000..ef1854926e94
--- /dev/null
+++ b/net/pppoa/pkg-descr
@@ -0,0 +1,14 @@
+Support for the Alcatel Speedtouch USB device. This driver is GPL except
+for the file that is downloaded from the Alcatel site. This file is
+restricted, specifically in terms of distribution. See
+http://www.alcatel.com/consumer/dsl/disclaimer_lx.htm.
+
+
+Thanks to
+
+ Benoit Papillault, who made the linux driver.
+ Jorgen Lundman and Jon Barlow for their help and their time
+ porting the driver to *BSD.
+ And also all the contributors i forget.
+
+WWW: http://www.xsproject.org/speedtouch/
diff --git a/net/pppoa/pkg-plist b/net/pppoa/pkg-plist
new file mode 100644
index 000000000000..dd5256228c32
--- /dev/null
+++ b/net/pppoa/pkg-plist
@@ -0,0 +1,7 @@
+libdata/mgmt.o
+bin/modem_run
+bin/pppoa2
+etc/rc.d/adsl.sh.sample
+share/speedtouch/ppp.conf.sample
+share/speedtouch/INSTALL
+@dirrm share/speedtouch