aboutsummaryrefslogtreecommitdiffstats
path: root/net/pptpclient/Makefile
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2003-07-14 10:53:03 +0800
committersf <sf@FreeBSD.org>2003-07-14 10:53:03 +0800
commit971087c2b4d6b0b917e3fac3ac1334b04f7c9907 (patch)
tree7181a8316bbb1b7be4386d9173b3c6ace07025da /net/pptpclient/Makefile
parent0cc85c09b55a7d94ca1d7c16c8eedae091f2840c (diff)
downloadfreebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.tar.gz
freebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.tar.zst
freebsd-ports-gnome-971087c2b4d6b0b917e3fac3ac1334b04f7c9907.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead.
Diffstat (limited to 'net/pptpclient/Makefile')
-rw-r--r--net/pptpclient/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/net/pptpclient/Makefile b/net/pptpclient/Makefile
index 528089639a09..cd21d9023f68 100644
--- a/net/pptpclient/Makefile
+++ b/net/pptpclient/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pptpclient
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pptpclient
@@ -16,12 +17,15 @@ DISTFILES= pptp-linux-1.1.0-1.tar.gz
MAINTAINER= thomas@cuivre.fr.eu.org
COMMENT= PPTP client for establishing a VPN link with an NT server
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+USE_GETOPT_LONG=yes
-MAKE_ARGS= DEBUG="" \
- INCLUDE="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgnugetopt" \
- all
+.include <bsd.port.pre.mk>
+
+MAKE_ARGS= DEBUG=""
+.if ${OSVERSION} < 500041
+MAKE_ARGS+= INCLUDE="${CPPFLAGS}" \
+ LIBS="${LDFLAGS}"
+.endif
GUNZIP_CMD= ${GZIP_CMD} ${EXTRACT_BEFORE_ARGS}
@@ -39,4 +43,4 @@ do-install:
${INSTALL_DATA} ${FILESDIR}/README ${PREFIX}/share/examples/pptpclient
${INSTALL_DATA} ${FILESDIR}/ppp.conf ${PREFIX}/share/examples/pptpclient
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>