aboutsummaryrefslogtreecommitdiffstats
path: root/net/py-gntp
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2012-09-03 04:05:13 +0800
committernivit <nivit@FreeBSD.org>2012-09-03 04:05:13 +0800
commitabcc1c7ee4b78397e43b4239022de2ddde036a83 (patch)
treefab8698dc92e79a142ead35cba2fe22e87af976e /net/py-gntp
parent03869670ba611a96325a311a3497b1682e45a8e8 (diff)
downloadfreebsd-ports-gnome-abcc1c7ee4b78397e43b4239022de2ddde036a83.tar.gz
freebsd-ports-gnome-abcc1c7ee4b78397e43b4239022de2ddde036a83.tar.zst
freebsd-ports-gnome-abcc1c7ee4b78397e43b4239022de2ddde036a83.zip
Python library for working with the `Growl Notification Transport
Protocol ( http://www.growlforwindows.com/gfw/help/gntp.aspx ) It should work as a dropin replacement for the older Python bindings. WWW: http://github.com/kfdm/gntp/
Diffstat (limited to 'net/py-gntp')
-rw-r--r--net/py-gntp/Makefile39
-rw-r--r--net/py-gntp/distinfo2
-rw-r--r--net/py-gntp/pkg-descr6
-rw-r--r--net/py-gntp/pkg-plist35
4 files changed, 82 insertions, 0 deletions
diff --git a/net/py-gntp/Makefile b/net/py-gntp/Makefile
new file mode 100644
index 000000000000..0f1f6c0fd616
--- /dev/null
+++ b/net/py-gntp/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= gntp
+PORTVERSION= 0.7
+#PORTREVISION= 0
+CATEGORIES= net
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Growl Notification Transport Protocol for Python
+
+LICENSE= MIT
+
+GH_ACCOUNT= kfdm
+GH_COMMIT= e177c37
+GH_TAGNAME= master
+
+OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
+OPTIONS_DEFINE= DOCS
+
+USE_GITHUB= yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.options.mk>
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+BUILD_DEPENDS+= sphinx-build:${PORTSDIR}/textproc/py-sphinx
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+PYDISTUTILS_BUILD_TARGET+= build_sphinx
+
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/build/sphinx/html && ${COPYTREE_SHARE} . ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/py-gntp/distinfo b/net/py-gntp/distinfo
new file mode 100644
index 000000000000..bbeae6699d59
--- /dev/null
+++ b/net/py-gntp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gntp-0.7.tar.gz) = 033580db5bd4a779907b0ee8292fee3ebeab7f22844ad3bcf29ab05f5e1ea3e8
+SIZE (gntp-0.7.tar.gz) = 37939
diff --git a/net/py-gntp/pkg-descr b/net/py-gntp/pkg-descr
new file mode 100644
index 000000000000..35db69523714
--- /dev/null
+++ b/net/py-gntp/pkg-descr
@@ -0,0 +1,6 @@
+Python library for working with the `Growl Notification Transport
+Protocol ( http://www.growlforwindows.com/gfw/help/gntp.aspx )
+
+It should work as a dropin replacement for the older Python bindings.
+
+WWW: http://github.com/kfdm/gntp/
diff --git a/net/py-gntp/pkg-plist b/net/py-gntp/pkg-plist
new file mode 100644
index 000000000000..4bead7c04028
--- /dev/null
+++ b/net/py-gntp/pkg-plist
@@ -0,0 +1,35 @@
+@comment $FreeBSD$
+bin/gntp
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+%%PORTDOCS%%%%DOCSDIR%%/.buildinfo
+%%PORTDOCS%%%%DOCSDIR%%/_sources/core.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/index.txt
+%%PORTDOCS%%%%DOCSDIR%%/_static/ajax-loader.gif
+%%PORTDOCS%%%%DOCSDIR%%/_static/basic.css
+%%PORTDOCS%%%%DOCSDIR%%/_static/comment-bright.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/comment-close.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/comment.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/default.css
+%%PORTDOCS%%%%DOCSDIR%%/_static/doctools.js
+%%PORTDOCS%%%%DOCSDIR%%/_static/down-pressed.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/down.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/file.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/jquery.js
+%%PORTDOCS%%%%DOCSDIR%%/_static/minus.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/plus.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/pygments.css
+%%PORTDOCS%%%%DOCSDIR%%/_static/searchtools.js
+%%PORTDOCS%%%%DOCSDIR%%/_static/sidebar.js
+%%PORTDOCS%%%%DOCSDIR%%/_static/underscore.js
+%%PORTDOCS%%%%DOCSDIR%%/_static/up-pressed.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/up.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/websupport.js
+%%PORTDOCS%%%%DOCSDIR%%/core.html
+%%PORTDOCS%%%%DOCSDIR%%/genindex.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/objects.inv
+%%PORTDOCS%%%%DOCSDIR%%/search.html
+%%PORTDOCS%%%%DOCSDIR%%/searchindex.js
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/_static
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/_sources
+%%PORTDOCS%%@dirrm %%DOCSDIR%%