aboutsummaryrefslogtreecommitdiffstats
path: root/net/py-ldap2
diff options
context:
space:
mode:
authorvsevolod <vsevolod@FreeBSD.org>2005-07-25 22:33:19 +0800
committervsevolod <vsevolod@FreeBSD.org>2005-07-25 22:33:19 +0800
commit6e5af9e507a984be64f12012cc2d39727b327026 (patch)
tree6a94ad0483122a017fa494f2d1d2ede5ddfb6c8b /net/py-ldap2
parent358bbe3d7bdffce6034277819a52925d86e379b5 (diff)
downloadfreebsd-ports-gnome-6e5af9e507a984be64f12012cc2d39727b327026.tar.gz
freebsd-ports-gnome-6e5af9e507a984be64f12012cc2d39727b327026.tar.zst
freebsd-ports-gnome-6e5af9e507a984be64f12012cc2d39727b327026.zip
Add WITH_SASL option.
PR: ports/83145 Submitted by: Boris Samorodov <bsam@ipt.ru> Approved by: perky (mentor)
Diffstat (limited to 'net/py-ldap2')
-rw-r--r--net/py-ldap2/Makefile29
1 files changed, 25 insertions, 4 deletions
diff --git a/net/py-ldap2/Makefile b/net/py-ldap2/Makefile
index 0caec0ea84d1..b2e8489afb2f 100644
--- a/net/py-ldap2/Makefile
+++ b/net/py-ldap2/Makefile
@@ -6,6 +6,7 @@
PORTNAME= ldap2
PORTVERSION= 2.0.8
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= python-ldap
@@ -19,11 +20,31 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_OPENLDAP= yes
USE_REINPLACE= yes
+WANT_OPENLDAP_VER= 22
+
+REPLACE_ARGS= -e 's=/opt/openldap-OPENLDAP_REL_ENG_2_2/include=${LOCALBASE}/include='
+
+.if defined(WITH_SASL)
+WANT_OPENLDAP_SASL= yes
+REPLACE_ARGS+= -e 's=/usr/include/sasl=${LOCALBASE}/include/sasl=' \
+ -e 's=/opt/openldap-OPENLDAP_REL_ENG_2_2/lib=${LOCALBASE}/lib ${LOCALBASE}/lib/sasl2='
+CONFLICTS+= openldap22-client-2.*
+.else
+REPLACE_ARGS+= -e 's=ldap_r lber ssl crypto sasl2=ldap_r lber ssl crypto=' \
+ -e 's=/opt/openldap-OPENLDAP_REL_ENG_2_2/lib=${LOCALBASE}/lib='
+.endif
+
+pre-everything::
+ @${ECHO} "============================================================="
+ @${ECHO}
+ @${ECHO} "You can build ${PKGNAME} with the following options:"
+ @${ECHO}
+ @${ECHO} "WITH_SASL with (Cyrus) SASL2 support"
+ @${ECHO}
+ @${ECHO} "============================================================="
+ @${ECHO}
do-configure:
- @${REINPLACE_CMD} -e "s=/opt/openldap-OPENLDAP_REL_ENG_2_2/lib=${LOCALBASE}/lib=" \
- -e "s=/opt/openldap-OPENLDAP_REL_ENG_2_2/include=${LOCALBASE}/include=" \
- -e "s=ldap_r lber ssl crypto sasl2=ldap_r lber ssl crypto=" \
- ${WRKSRC}/setup.cfg
+ @${REINPLACE_CMD} ${REPLACE_ARGS} ${WRKSRC}/setup.cfg
.include <bsd.port.mk>