aboutsummaryrefslogtreecommitdiffstats
path: root/net/py-python-heatclient
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2016-12-18 01:13:27 +0800
committernovel <novel@FreeBSD.org>2016-12-18 01:13:27 +0800
commita9611c21448754cb08f69f7436916859f892d66e (patch)
tree9ace783ff579bf6c675dda63adc996ed8dd05a91 /net/py-python-heatclient
parentb367f232eec41bec4af86ad26e87e31589cf5efa (diff)
downloadfreebsd-ports-gnome-a9611c21448754cb08f69f7436916859f892d66e.tar.gz
freebsd-ports-gnome-a9611c21448754cb08f69f7436916859f892d66e.tar.zst
freebsd-ports-gnome-a9611c21448754cb08f69f7436916859f892d66e.zip
net/py-heatclient: complete rename to net/py-python-heatclient
Should have been done as a part of my previous commit (r428767), but somehow forgot to svn mv for this one. Reported by: antoine
Diffstat (limited to 'net/py-python-heatclient')
-rw-r--r--net/py-python-heatclient/Makefile36
-rw-r--r--net/py-python-heatclient/distinfo3
-rw-r--r--net/py-python-heatclient/pkg-descr4
3 files changed, 43 insertions, 0 deletions
diff --git a/net/py-python-heatclient/Makefile b/net/py-python-heatclient/Makefile
new file mode 100644
index 000000000000..6fb3f1bee30c
--- /dev/null
+++ b/net/py-python-heatclient/Makefile
@@ -0,0 +1,36 @@
+# Created by: Alexander Nusov <alexander.nusov@nfvexpress.com>
+# $FreeBSD$
+
+PORTNAME= python-heatclient
+PORTVERSION= 1.6.1
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= alexander.nusov@nfvexpress.com
+COMMENT= OpenStack Orchestration API Client Library
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.8:devel/py-pbr
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.10.0:www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}swiftclient>=2.2.0:databases/py-swiftclient \
+ ${PYTHON_PKGNAMEPREFIX}oslo.utils>=3.18.0:devel/py-oslo.utils \
+ ${PYTHON_PKGNAMEPREFIX}oslo.serialization>=1.10.0:devel/py-oslo.serialization \
+ ${PYTHON_PKGNAMEPREFIX}oslo.i18n>=2.1.0:devel/py-oslo.i18n \
+ ${PYTHON_PKGNAMEPREFIX}osc-lib>=1.2.0:devel/py-osc-lib \
+ ${PYTHON_PKGNAMEPREFIX}keystoneauth1>=2.14.0:devel/py-keystoneauth1 \
+ ${PYTHON_PKGNAMEPREFIX}iso8601>=0.1.11:devel/py-iso8601 \
+ ${PYTHON_PKGNAMEPREFIX}cliff>=2.2.0:devel/py-cliff \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=3.10.0:devel/py-yaml \
+ ${PYTHON_PKGNAMEPREFIX}prettytable>=0:devel/py-prettytable \
+ ${PYTHON_PKGNAMEPREFIX}Babel>=2.3.4:devel/py-babel
+
+NO_ARCH= yes
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/net/py-python-heatclient/distinfo b/net/py-python-heatclient/distinfo
new file mode 100644
index 000000000000..9283421b1eaa
--- /dev/null
+++ b/net/py-python-heatclient/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1481114236
+SHA256 (python-heatclient-1.6.1.tar.gz) = 72141d0889694c913a58e8940eeb308f26ec87af6a6382fa71b400a0cdd331fd
+SIZE (python-heatclient-1.6.1.tar.gz) = 177069
diff --git a/net/py-python-heatclient/pkg-descr b/net/py-python-heatclient/pkg-descr
new file mode 100644
index 000000000000..0c0a7d7bba62
--- /dev/null
+++ b/net/py-python-heatclient/pkg-descr
@@ -0,0 +1,4 @@
+This is a client library for Heat built on the Heat orchestration API. It
+provides a Python API (the heatclient module) and a command-line tool (heat).
+
+WWW: http://pypi.python.org/pypi/python-heatclient