aboutsummaryrefslogtreecommitdiffstats
path: root/net/py-smb/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-01-11 21:21:41 +0800
committerijliao <ijliao@FreeBSD.org>2002-01-11 21:21:41 +0800
commita0b6ad7eb298f31acd40d7757ae32ef9d9c09668 (patch)
treed8d1a9074af3ae1b3f34ed1542ee3e99af54b786 /net/py-smb/Makefile
parent7da89cd850f9818c7b6e350c59169e78ee1b9d08 (diff)
downloadfreebsd-ports-gnome-a0b6ad7eb298f31acd40d7757ae32ef9d9c09668.tar.gz
freebsd-ports-gnome-a0b6ad7eb298f31acd40d7757ae32ef9d9c09668.tar.zst
freebsd-ports-gnome-a0b6ad7eb298f31acd40d7757ae32ef9d9c09668.zip
add py-smb 0.3.1
SMB/CIFS library written in Python
Diffstat (limited to 'net/py-smb/Makefile')
-rw-r--r--net/py-smb/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/net/py-smb/Makefile b/net/py-smb/Makefile
new file mode 100644
index 000000000000..744140e7cc1d
--- /dev/null
+++ b/net/py-smb/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# Ports collection makefile for: pysmb
+# Date created: Jan 11, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= smb
+PORTVERSION= 0.3.1
+CATEGORIES= net python
+MASTER_SITES= http://miketeo.net/projects/pysmb/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pysmb-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+WRKSRC= ${WRKDIR}/pysmb
+NO_BUILD= yes
+
+do-install:
+.for file in nmb.py smb.py
+ ${INSTALL_SCRIPT} ${WRKSRC}/${file} ${PYTHON_SITELIBDIR}
+.endfor
+.for file in nmbquery smbcp smbdu smblistshare
+ ${INSTALL_SCRIPT} ${WRKSRC}/${file} ${PREFIX}/bin
+.endfor
+ @${MKDIR} ${PREFIX}/share/py-smb
+ ${CP} ${WRKSRC}/extra/*.reg ${PREFIX}/share/py-smb
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/py-smb
+ ${CP} ${WRKSRC}/README ${PREFIX}/share/doc/py-smb
+ ${CP} ${WRKSRC}/docs/*.html ${WRKSRC}/docs/*.gif ${PREFIX}/share/doc/py-smb
+.endif
+
+.include <bsd.port.mk>