aboutsummaryrefslogtreecommitdiffstats
path: root/net/py-txamqp/Makefile
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2013-05-12 12:52:39 +0800
committerrm <rm@FreeBSD.org>2013-05-12 12:52:39 +0800
commit08774d0934b2eab3fa70b0ddebb6ba1a8dd5a125 (patch)
treef0e57892678d162f505d2873171f9d5c7088750f /net/py-txamqp/Makefile
parent81925b6f5fa9398a72f691d1dae722536ab3ad69 (diff)
downloadfreebsd-ports-gnome-08774d0934b2eab3fa70b0ddebb6ba1a8dd5a125.tar.gz
freebsd-ports-gnome-08774d0934b2eab3fa70b0ddebb6ba1a8dd5a125.tar.zst
freebsd-ports-gnome-08774d0934b2eab3fa70b0ddebb6ba1a8dd5a125.zip
- fix pkg-plist
- bump PORTREVISION while here: - trim Makefile header - eliminate PYTHON_SITELIBDIR from depends - limit python version to 2.x only (print/except) Reported by: pointyhat (miwi)
Diffstat (limited to 'net/py-txamqp/Makefile')
-rw-r--r--net/py-txamqp/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/net/py-txamqp/Makefile b/net/py-txamqp/Makefile
index 34b819838694..cb24161c4820 100644
--- a/net/py-txamqp/Makefile
+++ b/net/py-txamqp/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: txamqp
-# Date created: 2009-07-04
-# Whom: Bruce Simpson
-#
+# Created by: Bruce Simpson
# $FreeBSD$
-#
PORTNAME= txamqp
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= net python
MASTER_SITES= http://launchpadlibrarian.net/30388120/ \
# http://launchpad.net/txamqp/trunk/${PORTVERSION}/+download/
@@ -16,17 +13,17 @@ DISTNAME= python-${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= ports@FreeBSD.org
COMMENT= Twisted Python library for the AMQP messaging protocol
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/thrift/__init__.py:${PORTSDIR}/devel/py-thrift
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}thrift>0:${PORTSDIR}/devel/py-thrift
-USE_PYTHON= 2.5+
-USE_PYDISTUTILS= easy_install
+USE_PYTHON= -2.7
+USE_PYDISTUTILS=easy_install
USE_TWISTED= yes
WRKSRC= ${WRKDIR}/python-${PORTNAME}-${PORTVERSION}
PYDISTUTILS_PKGNAME= txAMQP
PYDISTUTILS_PKGVERSION= 0.3
-PLIST_SUB= PORTNAME="${PORTNAME}"
+PLIST_SUB= PORTNAME="${PORTNAME}"
# TODO: Install txAMQP examples.